Otoro LED stays lit after disconnecting from mains following full charge

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: benfrancis, Assigned: bechen)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Device: Otoro

STR:
* Charge the device until it is fully charged
* Unplug from charger

Expected:
I'm not actually sure what is supposed to happen, but I'm guessing the green LED lights up to tell you that the device is fully charged, then should turn off when you unplug the device from the charger?

Actual:
LED turns on once fully charged, but when you unplug it stays lit until you next reboot.

Side note:
I'm actually curious to know where this code lives and how much control we have over the LED. I've seen some interesting looking drivers hanging around in the codebase and wondered if we could use the LED for other things too (like flashing/pulsing for notifications).
I feel like this didn't used to happen.  Either way, sounds very bad :)
blocking-basecamp: ? → +
s/didn't used to happen/wasn't the behaviour in the past/  Man, poor grammar today.
Assignee: nobody → bechen
I can still reproduce this.
(Assignee)

Comment 4

6 years ago
Created attachment 673772 [details] [diff] [review]
Update the battery indicator led when receiving battery status change.
Attachment #673772 - Flags: review?(jones.chris.g)
Comment on attachment 673772 [details] [diff] [review]
Update the battery indicator led when receiving battery status change.

Looks great!
Attachment #673772 - Flags: review?(jones.chris.g) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e2e341820373
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/29fbf1fd2cb6
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Duplicate of this bug: 803563
You need to log in before you can comment on or make changes to this bug.