Closed Bug 797834 Opened 8 years ago Closed 8 years ago

build error on OSX 10.6 in widget cocoa

Categories

(Core :: Widget: Cocoa, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla18

People

(Reporter: emannion, Assigned: smichaud)

References

Details

Attachments

(1 file)

On building the tip of the Alder branch I get this error below.

I'm on OSX 10.6, building using clang.  I do not get this error using 10.7

Users/Enda/code/mozilla/alder_default/alder/widget/cocoa/nsMacWebAppUtils.mm:49:34: error: implicit conversion of NULL constant to 'NSWorkspaceLaunchOptions' (aka 'unsigned long')
      [-Werror,-Wnull-conversion]
                        options: nil
                                 ^~~
/System/Library/Frameworks/CoreServices.framework/Headers/../Frameworks/CarbonCore.framework/Headers/MacTypes.h:69:17: note: expanded from macro 'nil'
    #define nil NULL
                ^~~~
1 error generated.
make[6]: *** [nsMacWebAppUtils.o] Error 1
make[6]: *** Waiting for unfinished jobs....
make[5]: *** [libs] Error 2
make[4]: *** [libs_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2 


Replacing the nil with a 0  got me past this.
Duplicate of this bug: 797955
The code that triggers this error has been in the tree for a while (since http://hg.mozilla.org/mozilla-central/rev/4cffe2b37d0c landed in July), and hasn't triggered an error before now.  But maybe the build infrastructure is different for branches like alder and fx-team.

In any case this *is* a real error.  Patch coming up shortly.
Attached patch FixSplinter Review
Assignee: nobody → smichaud
Attachment #668092 - Flags: review?(dwalkowski)
Comment on attachment 668092 [details] [diff] [review]
Fix

It's a bitfield, so yes, a zero is more correct than null.
And casting it to the correct flavor is helpful documentation.
Attachment #668092 - Flags: review?(dwalkowski) → review+
I was getting this error on m-c, too. I have no idea why it suddenly showed up. Thanks for fixing it!
Duplicate of this bug: 798483
https://hg.mozilla.org/mozilla-central/rev/2849c2156345
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.