Closed Bug 797964 Opened 7 years ago Closed 7 years ago

complete spdy ping experiment

Categories

(Core :: Networking: HTTP, enhancement)

16 Branch
x86_64
Linux
enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla19

People

(Reporter: mcmanus, Assigned: mcmanus)

Details

Attachments

(2 files, 2 obsolete files)

we've had an experiement for a while (bug 729736) to see if any different intervals of the spdy ping had higher failure rates.

It turns out there isn't much there. (graphs to be attached). values from 10 to 110 have similar pass and fail rates.

I'll remove the experiment and update the threshold to 58 (just a touch under 60) - this shows we don't need to be particularly concerned about a particular value, but it is still a battery vs latency tradeoff that we can feel better about eeking out a little battery and making that session last a little longer.
Attached patch patch 0Splinter Review
Attachment #668093 - Flags: review?(honzab.moz)
Attached image fail distribution (obsolete) —
Attached image pass distribution (obsolete) —
Attachment #668093 - Flags: review?(honzab.moz) → review+
thanks honza.

fyi I've decided not to push this right away due to bug 798423 - the false fails caused by that bug could plausibly be swamping interesting values that this telemetry would show. We'll get some more data with that fixed. (I don't expect anything, but might as well find out)
Attachment #668094 - Attachment is obsolete: true
Attachment #668096 - Attachment is obsolete: true
Attached image failure distribution
attachment in comment 5 is the updated distribution using only data on nightly that includes the 798423 fix.

It is much more in line with what I would expect to see - failure spikes at 60 and 110. So the approach of changing our default from 44 to 58 seems right in that it minimizes ping traffic without crossing the 60 boundary.
https://hg.mozilla.org/mozilla-central/rev/5db0e8ad0b7d
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.