Closed Bug 797988 Opened 8 years ago Closed 8 years ago

[classic] No focus rect on header field buttons in message compose

Categories

(Toolkit :: Themes, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19

People

(Reporter: mnyromyr, Assigned: neil)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Attached patch draw focusrect for Linux (obsolete) — Splinter Review
Yeah, bug 178637 is back yet again (and for a while already, I should add). But this time, only Linux is broken, Windows/Mac look okay AFAICT.

This bug is valid for the classic theme only!

"Tabbing" through the header fields in the mail/news editor selects alternately a button and an input field, i.e. "Reply-To:" -> "kd-moz@tprac.de" -> "Newsgroup:" -> "de.comm.software.mozilla".

With the modern theme the button gets slightly darker, but with the classic theme you can't recognize anymore where you are. 'Some months ago', there was a focus rect visible upon the currently selected button.

The attached patch works for me, but feels rather awkward, tbh.
Attachment #668107 - Flags: review?(neil)
Attached patch Proposed patchSplinter Review
It looks as if I didn't copy the styles from Windows to Linux hard enough for bug 398874 - other Linux styles meant that some of them didn't take effect and others were unnecessary.
Attachment #668120 - Flags: feedback?(mnyromyr)
Comment on attachment 668120 [details] [diff] [review]
Proposed patch

Yeah, that looks definitely more useful.
Attachment #668120 - Flags: feedback?(mnyromyr) → feedback+
Attachment #668107 - Attachment is obsolete: true
Attachment #668107 - Flags: review?(neil)
Attachment #668120 - Flags: ui-review?(bwinton)
Assignee: mnyromyr → neil
Comment on attachment 668120 [details] [diff] [review]
Proposed patch

Steal!
Attachment #668120 - Flags: ui-review?(bwinton) → ui-review?(mconley)
> Attachment #668120 [details] [diff] - Flags: ui-review?(bwinton@mozilla.com) → ui-review?(mconley@mozilla.com)
Ping mconley.
Can somebody show me a screenshot of the header fields with, and without the patch?
This is the effect on my Linux system, running Gnome 3.
The focus is actually in the same place in both screen shots.
Attachment #677173 - Flags: ui-review?(mconley)
Comment on attachment 668120 [details] [diff] [review]
Proposed patch

LGTM - thanks!
Attachment #668120 - Flags: ui-review?(mconley) → ui-review+
Attachment #677173 - Flags: ui-review?(mconley)
Attachment #668120 - Flags: review?(gavin.sharp)
Component: MailNews: Composition → Themes
Product: SeaMonkey → Toolkit
Attachment #668120 - Flags: review?(gavin.sharp) → review?(enndeakin)
Attachment #668120 - Flags: review?(enndeakin) → review+
https://hg.mozilla.org/mozilla-central/rev/37018544448d
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.