Include Accessible-inl.h in nsMaiInterfaceTable.cpp

RESOLVED FIXED in mozilla18

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: espindola, Assigned: espindola)

Tracking

unspecified
mozilla18
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 668413 [details] [diff] [review]
include it

Accessible::Role is defined inline in Accessible-inl.h, so we have to include Accessible-inl.h in every file that uses it.

Found when a clang build failed to link because every other use of Accessible::Role was inlined.
Attachment #668413 - Flags: review?(surkov.alexander)
Attachment #668413 - Flags: review?(surkov.alexander) → review+
Duplicate of this bug: 798139

Comment 3

6 years ago
https://hg.mozilla.org/mozilla-central/rev/85d794aadac9
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
You need to log in before you can comment on or make changes to this bug.