Unable to launch Metro Firefox in Preview

RESOLVED DUPLICATE of bug 797013

Status

RESOLVED DUPLICATE of bug 797013
6 years ago
4 years ago

People

(Reporter: greggkeizer, Unassigned)

Tracking

Trunk
x86
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.17 Safari/537.11

Steps to reproduce:

Installed Preview (http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-elm/firefox-18.0a1.en-US.win32.installer.exe) on multiple VMs (on Macs, VMware's Fusion 5) with Windows 8 RTM Evaluation as guest. Set Nightly as default browser, both using the ensuing pop-up and via the Control Panel. No other Firefox on the VM.


Actual results:

The Start Screen tile (shows Nightly) opens the desktop version of the browser when clicked. No access, then, to the Metro-ized version.

IE10 -- since it's been denied the default -- exhibits the same behavior, which is to be expected, so it appears to be some kind of problem registering the browser as default.

Multiple uninstalls-reinstalls did not solve the problem.

Nor did Brian Bondy's suggestion to (in his blog post) to run the attachment from Bugzilla (https://bugzilla.mozilla.org/show_bug.cgi?id=794433) to clear Registry entries prior to reinstalling Nightly. 


Expected results:

Clicking the Nightly tile in Metro should have opened the Metro-ized version of the Preview.

Comment 1

6 years ago
Exact same problem here, with the exact same steps taken. Execpt I'm running Windows 8 RTM fully installed.
Will are you using Windows 8 x86?

Comment 3

6 years ago
Yes...32-bit

Updated

6 years ago
OS: Mac OS X → Windows 8 Metro

Updated

6 years ago
Component: Untriaged → Shell
Depends on: 798805
Product: Firefox → Firefox for Metro
Version: 18 Branch → Trunk
Depends on: 734628

Comment 4

6 years ago
The fix for these issues 734628 798805 appears to fix the installation issue on 32-bit platforms, however, the "metro" browser crashes while loading.  I tested it on an internal reference platform and a samsung ATIV Smart PC.  These are both Atom based 32-bit tablets.

Comment 5

6 years ago
Using the latest nightly build of 19 I get similar. I get the blue launch screen but then nothing. I left it and watched it for about 10 minutes but didn't launch fully. I left it over night (about 7 hours) and Windows was back to the start screen so at some point it must have crashed.

This is with Windows 8 Professional - public version (upgraded the other day from Win 7 Home Premium). 32-bit.
I can reproduce this same crash but it's fixed by the patch in Bug 797013 which will land soon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797013
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.