Last Comment Bug 798437 - aboutSocialError.xhtml doesn't include Social.jsm with the right url
: aboutSocialError.xhtml doesn't include Social.jsm with the right url
Status: RESOLVED FIXED
[qa-]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: 18 Branch
: All All
: -- normal (vote)
: Firefox 18
Assigned To: Mike Hommey [:glandium]
:
: Shane Caraveo (:mixedpuppy)
Mentors:
Depends on:
Blocks: metro-build
  Show dependency treegraph
 
Reported: 2012-10-05 10:14 PDT by Mike Hommey [:glandium]
Modified: 2012-10-17 16:36 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Fix Social.jsm url in aboutSocialError.xhtml (1.00 KB, patch)
2012-10-05 10:15 PDT, Mike Hommey [:glandium]
felipc: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-10-05 10:14:35 PDT

    
Comment 1 Mike Hommey [:glandium] 2012-10-05 10:15:39 PDT
Created attachment 668496 [details] [diff] [review]
Fix Social.jsm url in aboutSocialError.xhtml
Comment 2 :Felipe Gomes (needinfo me!) 2012-10-05 17:58:37 PDT
I'll roll up this change together with the patches from bug 766616 when uplifiting it to aurora

https://hg.mozilla.org/integration/mozilla-inbound/rev/c4bb09009a54
Comment 3 Phil Ringnalda (:philor) 2012-10-05 20:29:22 PDT
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/9b9678df7672 because something in the push was hitting "browser_frameworker.js | sub-test testEarlyClose failed: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXPCComponents_Utils.nukeSandbox]" nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame :: resource://gre/modules/FrameWorker.jsm :: terminate :: line 239" data: no]" and "browser_frameworker.js | check that websockets worked - Got FAILED calling WebSocket constructor: TypeError: WebSocket is not a constructor, expected ok" and I didn't know which (though I presume bug 790201), and didn't know interconnectedness among them.
Comment 4 Mark Hammond [:markh] 2012-10-06 00:08:41 PDT
relanded: https://hg.mozilla.org/integration/mozilla-inbound/rev/43f7b44fcf15
Comment 5 Ed Morley [:emorley] 2012-10-06 12:42:14 PDT
https://hg.mozilla.org/mozilla-central/rev/43f7b44fcf15
Comment 6 :Felipe Gomes (needinfo me!) 2012-10-07 03:56:32 PDT
fixed in aurora with cset https://hg.mozilla.org/releases/mozilla-aurora/rev/b69ca3697450
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-10-17 16:36:30 PDT
Flagging [qa-] as I don't think this needs QA verification. Please correct me if I am wrong.

Note You need to log in before you can comment on or make changes to this bug.