location bar shows history when only bookmarks is selected

RESOLVED DUPLICATE of bug 751709

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 751709
6 years ago
6 years ago

People

(Reporter: James, Unassigned)

Tracking

15 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 668780 [details]
Visited mydomain, not in bookmarks, started typing my and it auto completed the whole thing shown by the highlighted blue area.

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120905151427

Steps to reproduce:

For location bar settings I have it set to only Bookmarks.  I visit a webpage I've never been to.  Go to the location bar and start typing the website again it will autocomplete the website even though its not in my bookmarks.  It won't show the history but does show the website itself autocompleted.  If I visited any other pages from that site and I keep typing the url for that page it will also autocomplete that url.

Example: I visit www.mydomain.com/  Close out my browser.  Reopen and start to type www.my and it will try to autocomplete www.mydomain.com  It won't show in the dropdown but the address bar will show it autocompleted.

If I visit www.mydomain.com/test If I type in www.mydomain.com/t it will autocomplete www.mydomain.com/test  I was only able to get this to happen some of the time.

If I use the clear history for everything or within the time limit I can remove the site from autocompleting.  If I go in to the "Show all history" and just try to delete or use the "Forget this site" it doesn't remove the site from autocompleting in the location bar.


Actual results:

Location bar is autocompleting history sites even though only show bookmarks is selected in the settings


Expected results:

It shouldn't be autocompleting sites from history if only bookmarks is selected for the location bar and if for some reason it should, then when deleting from the "Show all history" section should remove it from autocompleting in the location bar.
(Reporter)

Comment 1

6 years ago
Forgot to mention that if I change the location bar settings to show history and start typing my I get the site in the dropdown and I can then delete the entry solving the "Show all history" deletion issue of not removing the site from the autocomplete.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751709
(Reporter)

Comment 3

6 years ago
(In reply to Bill Gianopoulos [:WG9s] from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 751709 ***

There is another issue that I don't think will be solved by the duplicate issue.

The autocomplete results still show sites that are manually removed through the "Show all history" page.

Unless you use the "Clear recent history" option the site is never removed from the autocomplete.
You need to log in before you can comment on or make changes to this bug.