autoFill should obey history-only or bookmarks-only autocomplete options

VERIFIED FIXED in Firefox 34

Status

()

defect
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: mak, Unassigned)

Tracking

unspecified
Firefox 34
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by UnifiedComplete])

See https://bugzilla.mozilla.org/show_bug.cgi?id=740076#c12

Briefly, we will obey the simple "enabled" pref, but not the advanced behavior of limiting results to history or bookmarks...
It may also be tricky considered the many combination the autocomplete algorithm may have.
Depending on the direction of bug 530209 this may even end up being a wontfix (if for example we'd define an Autocomplete section that gets disabled/disappears when it's unchecked, with options inside it that clarify they refer to the popup results).
Duplicate of this bug: 752509
Duplicate of this bug: 775421
If we can't have autoFill properly filter results based on their state according to the preference, why not just disable it entirely when you select a non-default value for browser.urlbar.default.behavior (in addition to when autocomplete.enabled is false)?
Is there any progress on this one? Looks like this new behaviour is known since the dev days of FF14. But unfortunately this has been silently removed from the feature list, but not from the preferences interface.

Gavin: Me? Or Marco?
My comment was addressed to the general audience of would-be bug fixers, including but not limited to Marco :)
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)
> If we can't have autoFill properly filter results based on their state
> according to the preference, why not just disable it entirely when you
> select a non-default value for browser.urlbar.default.behavior (in addition
> to when autocomplete.enabled is false)?

+1, I think this is the best way on.
Duplicate of this bug: 798785
Can’t quite understand why FF has contradicting behaviour here:
I've selected to just use bookmarks... and in the dropdown list that pops up, this actually works,... but the address bar itself is auto-completed with some of the domains from the history.

Not just illogical, but also quite annoying; and this is new behaviour since some version
it needs much deeper changes to properly distinguish history and bookmarks there, I'm going to file a bug to implement comment 3.
Depends on: 810930
Duplicate of this bug: 844699
fixed in UnifiedComplete.

The fix makes so that we act properly for bookmarks or history, for more complicated behaviors we disable autoFill.
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1043942
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Whiteboard: [fixed by UnifiedComplete]
Andrei, if you've already verified this in some other UnifiedComplete bug, you can go ahead and qe-verify- this. Thanks!
Flags: qe-verify+
QA Contact: andrei.vaida
(In reply to Liz Henry :lizzard from comment #12)
> Andrei, if you've already verified this in some other UnifiedComplete bug,
> you can go ahead and qe-verify- this. Thanks!

Yes, the functionality behind "When using the location bar, suggest" preference has already been tested and confirmed as working properly.
Status: RESOLVED → VERIFIED
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.