If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Back" after "Options" just returns to the first dialog

VERIFIED FIXED in Firefox 21

Status

()

Firefox
Installer
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Mardak, Assigned: rstrong)

Tracking

Trunk
Firefox 23
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 wontfix, firefox21 verified, firefox22 verified, firefox23 verified)

Details

(Whiteboard: [stub=])

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Not sure if it's intended, but the options view of the installer lets the user go back to the first screen which says "Thanks for choosing Nightly. We're not just designed to be different, we're different by design. Click to install."

It seems unnecessary to have the Back button and just let the user choose between Install and Cancel. ? But that's a UX decision.
(Reporter)

Comment 1

5 years ago
Bug 797989 seems to be running into some confusion about the purpose of the back button. Turns out it's more of a reset/undo-everything.
Blocks: 797989
It was designed this way by UX. I'll leave it to UX as to whether it should be removed.

Updated

5 years ago
Blocks: 322206

Updated

5 years ago
Whiteboard: [stub-]

Updated

5 years ago
Whiteboard: [stub-] → [stub=]
Created attachment 729366 [details]
Asscoiated UI

shorlander, I would like to remove the back button since it is seldom used (approximately 2.22% of the time) as well as to fix bug 797989 since it is unclear if the back button should retain the changes the user has made or reset the changes back to default. Also, it is just as easy to install from the Options page as it is from the intro page.

    Number of times the Intro page was shown
       |  Once  | Twice | > Twice | Total
       +--------+-------+---------+-------
Count  |  23998 |  547  |   60    | 24605
    %  | 97.53% | 2.22% |  0.24%  |
Attachment #729366 - Flags: ui-review?(shorlander)
Comment on attachment 729366 [details]
Asscoiated UI

Yeah, that makes sense to me.
Attachment #729366 - Flags: ui-review?(shorlander) → ui-review+
Created attachment 742744 [details]
screenshot

Stephen, do you have a preference as to whether the Options button is hidden or disabled on the options page. I think hidden is better though it does look somewhat more balanced with the transition from the intro page to the options page when it is just disabled.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #742744 - Flags: ui-review?(shorlander)
Created attachment 742745 [details] [diff] [review]
patch - hides the options button
Comment on attachment 742745 [details] [diff] [review]
patch - hides the options button

Let's go with the review on this. If it is decided that the options button should just be disabled it will only be a couple of lines to review.
Attachment #742745 - Flags: review?(netzen)
Attachment #742745 - Flags: review?(netzen) → review+
(In reply to Robert Strong [:rstrong] (do not email) from comment #5)
> Created attachment 742744 [details]
> screenshot
> 
> Stephen, do you have a preference as to whether the Options button is hidden
> or disabled on the options page. I think hidden is better though it does
> look somewhat more balanced with the transition from the intro page to the
> options page when it is just disabled.

I think we should just hide it, disabled might imply there is some way to re-enable it.
Attachment #742744 - Flags: ui-review?(shorlander) → ui-review+
(In reply to Stephen Horlander from comment #8)
> (In reply to Robert Strong [:rstrong] (do not email) from comment #5)
> > Created attachment 742744 [details]
> > screenshot
> > 
> > Stephen, do you have a preference as to whether the Options button is hidden
> > or disabled on the options page. I think hidden is better though it does
> > look somewhat more balanced with the transition from the intro page to the
> > options page when it is just disabled.
> 
> I think we should just hide it, disabled might imply there is some way to
> re-enable it.
Thanks and agreed! The patch is good to go as it stands.
Pushed to mozilla-inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/89063545e4b3
https://hg.mozilla.org/mozilla-central/rev/89063545e4b3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Comment on attachment 742745 [details] [diff] [review]
patch - hides the options button

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Stub installer / Bug 322206
User impact if declined: minimal. I'd like to get this uplifted even still since it simplifies the code and I'd prefer it to be released without this so it doesn't create the expectation of there being a back button
Testing completed (on m-c, etc.): manually verified on m-c
Risk to taking this patch (and alternatives if risky): minimal
String or IDL/UUID changes made by this patch: none
Attachment #742745 - Flags: approval-mozilla-beta?
Attachment #742745 - Flags: approval-mozilla-aurora?
Note: for other branches the l10n string removal won't be landed to avoid l10n churn
Comment on attachment 742745 [details] [diff] [review]
patch - hides the options button

As with any stub change, adding verifyme to make sure this doesn't impact installation.
Attachment #742745 - Flags: approval-mozilla-beta?
Attachment #742745 - Flags: approval-mozilla-beta+
Attachment #742745 - Flags: approval-mozilla-aurora?
Attachment #742745 - Flags: approval-mozilla-aurora+

Updated

4 years ago
Keywords: verifyme
Pushed to mozilla-aurora
https://hg.mozilla.org/releases/mozilla-aurora/rev/d418d84d4334

Pushed to mozilla-beta
https://hg.mozilla.org/releases/mozilla-beta/rev/83ec20324f65
status-firefox20: --- → wontfix
status-firefox21: --- → fixed
status-firefox22: --- → fixed
status-firefox23: --- → fixed

Comment 16

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:23.0) Gecko/20130506 Firefox/23.0

Verified as fixed with FF 21 beta 7 (Build ID: 20130430204233), latest Nightly (Build ID: 20130506030925) and latest Aurora (Build ID: 20130506004015). The Options button is no longer visible on the options page.
status-firefox21: fixed → verified

Comment 17

4 years ago
Mozilla/5.0 (Windows NT 6.0; rv:21.0) Gecko/20100101 Firefox/22.0

Verified as fixed with FF 22 beta 1 (Build ID: 20130514181517) and latest Nightly (Build ID: 20130515141643).
status-firefox22: fixed → verified
Verified as fixed on FF 23 beta 1 (build ID: 20130625125232)

User Agent:
Mozilla/5.0 (Windows NT 6.0; rv:23.0) Gecko/20100101 Firefox/23.0
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.