[New Tab Page] New Tab Page is shown in Private Browsing Mode (with Preloading active)

RESOLVED FIXED in Firefox 21

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: morpheus3k+bugzilla, Assigned: ttaubert)

Tracking

Trunk
Firefox 21
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

With "browser.newtab.preload" set to true, the New Tab Page is shown, if a new tab is opened in private browsing mode.

Steps to reproduce:
1. set browser.newtab.preload to true
2. restart Firefox
3. activate Private Browsing Mode
4. Open a new Tab

Expected:
New "Private Browsing" Information page should be displayed

Actual Result:
New Tab Page is shown
Blocks: 791670
WFM on the 10/15 Nightly.

Morpheus3k, can you reproduce this issue with a clean profile?
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(morpheus3k+bugzilla)
yes, I can reproduce this with the given steps on Windows 7 and OS X 10.8 with recent Nightly 2012-10-15.
Flags: needinfo?(morpheus3k+bugzilla)
I managed to reproduce this issue a couple of times too eventually. It didn't reproduce with every try, so I suppose it's intermittent.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 832177
Status: NEW → ASSIGNED
OS: Mac OS X → All
QA Contact: ttaubert
Hardware: x86 → All
Assignee: nobody → ttaubert
Attachment #708758 - Flags: review?(jaws)
QA Contact: ttaubert
Attachment #708758 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/964839e7a2d1
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
You need to log in before you can comment on or make changes to this bug.