Closed Bug 832177 Opened 9 years ago Closed 9 years ago

Opening a tab in Private window sometimes incorrectly shows about:newtab

Categories

(Firefox :: Private Browsing, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 799495

People

(Reporter: nmaier, Unassigned)

References

Details

Normally when opening a new tab in a Private window about:privatebrowsing will be opened automatically in that new tab.

Using the most recent Nightly (20130117) I however observed an instance where instead about:newtab was opened but only once.

What I remember doing:
- In a not so fresh session I opened a new private window (from keyboard shortcut)
- Browsed around on a page for a minute or two.
- Opened a new tab in that private window (keyboard shortcut)
-> about:newtab instead of about:privatebrowsing
-> Opening another tab aftwards will correctly show about:privatebrowsing

I also remember previously seeing this wrong behavior once a couple of days back, but at that time I only got thinking about it later after the window and tab were already gone and wasn't 100% sure it really happened. :p This time I'm sure, though.

However, please note that I wasn't able to reproduce this at all for now.
Might be some kind of race when first opening a new private window, e.g. some kind of race between BrowserNewTabPreloader and the private browsing code. 

I don't think this is more than a UI glitch: When clicking one of my about:newtab page icons in said private tab, the page opened with me not being logged in anymore, indicating my regular cookies were not sent in this private tab and hence indicating that the tab was indeed still private.
Have you set 'browser.newtab.preload' to true?

(I've seen this behavior with it enabled: Bug 799495)
Flags: needinfo?(MaierMan)
Yeah, I have browser.newtab.preload = true in my main browsing profile were I saw the issue.

So this might be a dupe of Bug 799495, or not since the PWPBM does have quite a few different code paths than legacy PBM.
Flags: needinfo?(MaierMan)
The code path is actually quite similar for the new tab page.  I think it's a dupe.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799495
You need to log in before you can comment on or make changes to this bug.