Last Comment Bug 799596 - Thunderbird is unusable after bug 565717 landed
: Thunderbird is unusable after bug 565717 landed
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: x86 All
: -- critical (vote)
: Thunderbird 19.0
Assigned To: Mike Conley (:mconley)
:
:
Mentors:
Depends on:
Blocks: 565717
  Show dependency treegraph
 
Reported: 2012-10-09 11:20 PDT by Mike Conley (:mconley)
Modified: 2012-10-09 11:53 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch v1 (2.53 KB, patch)
2012-10-09 11:39 PDT, Mike Conley (:mconley)
standard8: review+
Details | Diff | Splinter Review

Description Mike Conley (:mconley) 2012-10-09 11:20:21 PDT
Toolkit changed a string ID on us, which has rendered TB completely busted.

Specifically, we need to change spellCheckEnable.* to spellCheckToggle.*.
Comment 1 Mike Conley (:mconley) 2012-10-09 11:23:40 PDT
Cc'ing some folks from SeaMonkey, because I think this affects them too.
Comment 2 neil@parkwaycc.co.uk 2012-10-09 11:28:24 PDT
Fortunately we haven't switched our context menu over to toolkit entities yet ;-)
Comment 3 Mike Conley (:mconley) 2012-10-09 11:39:37 PDT
Created attachment 669653 [details] [diff] [review]
Patch v1

I didn't think it was 100% necessary to change the "spellCheckEnable" ID at http://mxr.mozilla.org/comm-central/source/mail/components/compose/content/messengercompose.xul#305

Let me know if I'm wrong on that.
Comment 4 Mike Conley (:mconley) 2012-10-09 11:50:16 PDT
Comment on attachment 669653 [details] [diff] [review]
Patch v1

Actually, I'll bet Mark is swamped. Redirecting to Magnus.
Comment 5 Mark Banner (:standard8, limited time in Dec) 2012-10-09 11:50:57 PDT
Comment on attachment 669653 [details] [diff] [review]
Patch v1

Agreed, we don't need to change the id.
Comment 6 Mike Conley (:mconley) 2012-10-09 11:53:23 PDT
Landed on comm-central as https://hg.mozilla.org/comm-central/rev/9a2ef9c8f412

Note You need to log in before you can comment on or make changes to this bug.