Closed Bug 799605 Opened 7 years ago Closed 7 years ago

Mirror mozbase -> m-c for bug 799288 and bug 799507

Categories

(Testing :: Mozbase, defect)

defect
Not set

Tracking

(firefox18 fixed)

RESOLVED FIXED
mozilla18
Tracking Status
firefox18 --- fixed

People

(Reporter: ahal, Assigned: k0scist)

References

Details

Attachments

(1 file, 1 obsolete file)

These bugs are currently blocking mochitest and reftest automation in b2g.

https://github.com/mozilla/mozbase/compare/mozilla-central...HEAD
Attachment #669667 - Flags: review?(wlachance)
This needs to be tested, somehow
Comment on attachment 669667 [details] [diff] [review]
c84d6da5669d9846719dac6e001348786b010874

Review of attachment 669667 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #669667 - Flags: review?(wlachance) → review+
We'll probably want to do a full try run due to the mozprocess change (which should also cover DM changes on fennec). For B2G I'll apply the patch on the desktop reftest machine. The b2g reftests are currently broken, but applying this patch to a clean m-c should fix them.
failure because of https://bugzilla.mozilla.org/show_bug.cgi?id=799681 ; retrying
Attachment #669667 - Attachment is obsolete: true
Attachment #669734 - Flags: review?(wlachance)
Comment on attachment 669734 [details] [diff] [review]
36a2f63be33af799a54d7f1511dc922730b10b22

ok
Attachment #669734 - Flags: review?(wlachance) → review+
pushed to try (again): https://tbpl.mozilla.org/?tree=Try&rev=438af9190775
Blocks: 800110
https://hg.mozilla.org/mozilla-central/rev/c0a7e188cc3e
Assignee: nobody → jhammel
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 669734 [details] [diff] [review]
36a2f63be33af799a54d7f1511dc922730b10b22

[Approval Request Comment]
Bug caused by (feature/regressing bug #): N/A
User impact if declined: This is test code needed to be able to run mochitest and other unittests on B2G in aurora.  No user impact.
Testing completed (on m-c, etc.): Green on m-c.
Risk to taking this patch (and alternatives if risky): It is possible, but very unlikely, that this could break desktop test harnesses on aurora, in which case it would be backed out.
String or UUID changes made by this patch: N/A
Attachment #669734 - Flags: approval-mozilla-aurora?
Comment on attachment 669734 [details] [diff] [review]
36a2f63be33af799a54d7f1511dc922730b10b22

Approving. Please make sure to keep an eye on this check-in & a= bajaj if it needs to be backed out
Attachment #669734 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This bug didn't have a valid resolved type, so I couldn't make changes to it without reopening it and re-fixing it.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Landed on aurora as https://hg.mozilla.org/releases/mozilla-aurora/rev/d5fd58f26db5, will watch the tree for breakage.
Target Milestone: mozilla19 → mozilla18
You need to log in before you can comment on or make changes to this bug.