The webapprt/components folder is getting left behind on uninstall of firefox installed through the stub installer

RESOLVED DUPLICATE of bug 798486

Status

()

Firefox
Installer
RESOLVED DUPLICATE of bug 798486
5 years ago
5 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Steps:

1. Install firefox with the stub installer using the latest-mozilla-aurora stub installer
2. Uninstall Aurora
3. Check C:\Program Files\Aurora

Expected:

Nothing should be there.

Actual:

An empty webapprt/components folder is left behind on uninstall.
(Reporter)

Comment 1

5 years ago
What's really strange about this bug is that only happens with the stub installer, not the regular installer, which I find bizarre. Any ideas?
Really shouldn't be happening any differently with the stub. I'll take a look in a bit
(Reporter)

Comment 4

5 years ago
Apparently also reproduces on Windows Vista. So this isn't an OS-specific bug.
OS: Windows XP → All
(Reporter)

Updated

5 years ago
Blocks: 322206
(In reply to Jason Smith [:jsmith] from comment #1)
> What's really strange about this bug is that only happens with the stub
> installer, not the regular installer, which I find bizarre. Any ideas?

Can you do a diff of the installation directory w/ and w/o stub? I suspect different versions are getting installed?
This might be tied to bug 757978, which was fixed about a month ago
See Also: → bug 757978
Ya I suspect the stub is getting an old version
Instead of a diff maybe just do about:buildconfig after each installation, but make sure you can reproduce it after you check the details of buildconfig.
(Reporter)

Comment 9

5 years ago
Created attachment 669778 [details]
Build Config for build downloaded by stub
(Reporter)

Updated

5 years ago
Attachment #669778 - Attachment description: Build Config → Build Config w/stub
Hrm that says aurora v16, shouldn't aurora be v17? and very very soon to be v18?
Attachment #669778 - Attachment description: Build Config w/stub → Build Config for build downloaded by stub
(Reporter)

Comment 11

5 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #10)
> Hrm that says aurora v16, shouldn't aurora be v17? and very very soon to be
> v18?

Sounds like this is exactly as you've described - we are getting an old build. bug 757978 was fixed on the FF 17 branch, but not FF 16.
(Reporter)

Comment 12

5 years ago
Created attachment 669787 [details]
Build Config for build downloaded without stub
(Reporter)

Comment 13

5 years ago
The changesets that each build is built from appears to be different:

- http://hg.mozilla.org/releases/mozilla-aurora/rev/8aac40fc9890
- http://hg.mozilla.org/releases/mozilla-aurora/rev/7588306df29e
(Reporter)

Comment 14

5 years ago
(In reply to Jason Smith [:jsmith] from comment #13)
> The changesets that each build is built from appears to be different:
> 
> - http://hg.mozilla.org/releases/mozilla-aurora/rev/8aac40fc9890
> - http://hg.mozilla.org/releases/mozilla-aurora/rev/7588306df29e

This confirms we are getting a different build here with the regular installer for aurora vs. the stub installer. The stub installer appears to be grabbing an older changeset on 10/2, where as the regular installer is using a changeset from 10/8.
I think we're seeing bug 798486.  Maybe the difference is only a day and one version is the migrated version and the other is not.
(Reporter)

Comment 16

5 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #15)
> I think we're seeing bug 798486.  Maybe the difference is only a day and one
> version is the migrated version and the other is not.

Yeah, I agree. Duping on that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798486
You need to log in before you can comment on or make changes to this bug.