Closed Bug 799780 Opened 7 years ago Closed 7 years ago

Remove gPrivateBrowsingUI.autoStarted and move that API to PrivateBrowsingUtils

Categories

(Firefox :: Private Browsing, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 19

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(1 file)

This simplifies a whole bunch of stuff.
Attached patch Patch (v1)Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #669816 - Flags: review?(josh)
Blocks: 799784
Attachment #669816 - Flags: review?(josh) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e26bb277c64
Target Milestone: --- → Firefox 19
Push backed out for causing frequent failures in browser_bug400731.js on debug mochitest-other (primarily OS X 10.6, but occurred on other platforms too):
eg https://tbpl.mozilla.org/php/getParsedLog.php?id=16010390&tree=Mozilla-Inbound

To see retriggers use:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=de6c6589ebe4&jobname=Rev4%20MacOSX%20Snow%20Leopard%2010.6%20mozilla-inbound%20debug%20test%20mochitest-other
(and press down to see the relevant range)

Backout:
https://hg.mozilla.org/integration/mozilla-inbound/rev/48557b9d07f2
Target Milestone: Firefox 19 → ---
Relanded with proof (https://tbpl.mozilla.org/?tree=Try&rev=0b822e1874cf) that this is kosher!

https://hg.mozilla.org/integration/mozilla-inbound/rev/129f5457378e

I believe the test failures were caused by bug 800394 which I fixed too.
https://hg.mozilla.org/mozilla-central/rev/129f5457378e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Comment on attachment 669816 [details] [diff] [review]
Patch (v1)

Review of attachment 669816 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/PrivateBrowsingUtils.jsm
@@ +15,5 @@
>                    .usePrivateBrowsing;
> +  },
> +
> +  get permanentPrivateBrowsing() {
> +#ifdef MOZ_PER_WINDOW_PRIVATE_BROWSING

Is "#ifdef" etc legitimate in a .jsm file? My local (inbound, debug) build is spewing "SyntaxError: illegal character" messages that seem to originate here.
Ah, it's supposed to be preprocessed... apparently my build still had a symlink back to the un-preprocessed file, and needed clobbering in order to pick this up properly. Sorry for the noise.
(In reply to comment #7)
> Ah, it's supposed to be preprocessed... apparently my build still had a symlink
> back to the un-preprocessed file, and needed clobbering in order to pick this
> up properly. Sorry for the noise.

No worries, this is not your fault.  Please file a bug in Core::Build Config to get this fixed.  Thanks!
You need to log in before you can comment on or make changes to this bug.