[OTA update] Update fails to locate update.xml file

RESOLVED FIXED

Status

P1
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: jgriffin)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

(Reporter)

Description

6 years ago
i tried to force an update on an older 10-05  build today, and it's failing to find the update.xml file.  is this due to the branch changes?    This blocks smoketests on Device to check daily updates.

Here's my logcat:

10-10 08:09:06.975: I/Gecko(8012): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:06.975: E/GeckoConsole(8012): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:06.975: I/Gecko(8012): *** AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 08:09:06.975: E/GeckoConsole(8012): AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 08:09:06.985: I/Gecko(8012): *** AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:06.985: E/GeckoConsole(8012): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:08.346: I/Gecko(8012): *** AUS:SVC Checker:onProgress - 571/571
10-10 08:09:08.346: E/GeckoConsole(8012): AUS:SVC Checker:onProgress - 571/571
10-10 08:09:08.346: I/Gecko(8012): *** AUS:SVC Checker:onLoad - request completed downloading document
10-10 08:09:08.346: E/GeckoConsole(8012): AUS:SVC Checker:onLoad - request completed downloading document
10-10 08:09:08.366: I/Gecko(8012): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:08.366: E/GeckoConsole(8012): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:09:08.366: I/Gecko(8012): *** AUS:SVC Checker:onLoad - number of updates available: 1
10-10 08:09:08.366: E/GeckoConsole(8012): AUS:SVC Checker:onLoad - number of updates available: 1
10-10 08:09:08.366: I/Gecko(8012): *** AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 08:09:08.366: E/GeckoConsole(8012): AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 08:09:08.376: I/Gecko(8012): *** AUS:SVC UpdateService:selectUpdate - skipping update because the update's application version is less than the current application version
10-10 08:09:08.376: E/GeckoConsole(8012): AUS:SVC UpdateService:selectUpdate - skipping update because the update's application version is less than the current application version
10-10 08:18:44.975: I/Gecko(8524): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:44.975: E/GeckoConsole(8524): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:44.975: I/Gecko(8524): *** AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 08:18:44.975: E/GeckoConsole(8524): AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 08:18:44.985: I/Gecko(8524): *** AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:44.985: E/GeckoConsole(8524): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:45.465: I/Gecko(8524): *** AUS:SVC Checker:onProgress - 571/571
10-10 08:18:45.465: E/GeckoConsole(8524): AUS:SVC Checker:onProgress - 571/571
10-10 08:18:45.465: I/Gecko(8524): *** AUS:SVC Checker:onLoad - request completed downloading document
10-10 08:18:45.465: E/GeckoConsole(8524): AUS:SVC Checker:onLoad - request completed downloading document
10-10 08:18:45.485: I/Gecko(8524): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:45.485: E/GeckoConsole(8524): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 08:18:45.485: I/Gecko(8524): *** AUS:SVC Checker:onLoad - number of updates available: 1
10-10 08:18:45.485: E/GeckoConsole(8524): AUS:SVC Checker:onLoad - number of updates available: 1
10-10 08:18:45.485: I/Gecko(8524): *** AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 08:18:45.485: E/GeckoConsole(8524): AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 08:18:45.495: I/Gecko(8524): *** AUS:SVC UpdateService:selectUpdate - skipping update because the update's application version is less than the current application version
10-10 08:18:45.495: E/GeckoConsole(8524): AUS:SVC UpdateService:selectUpdate - skipping update because the update's application version is less than the current application version

Repro;
1) install 10-05-2012 daily otoro build
2) force an update ping 
3) Verify no update is returned, and the logcat above can't find update.xml file

Expected:
- update available
The missing XML file isn't actually an error here, it looks like this is the relevant message:

"skipping update because the update's application version is less than the current application version"
(Assignee)

Comment 2

6 years ago
This happened because the nightlies are still on m-c (because gecko 18 wasn't uplifted to releases-mozilla-aurora) and so are gecko version 19.  However, the gecko version number in the update xml is hardcoded to 18.

As @marshall_law pointed out on IRC, we need to make the automation smarter so that it picks out the gecko version from application.ini.

In the meantime, I've updated the hardcoded version number in the update xml to 19.0a1.
(Reporter)

Comment 3

6 years ago
Okay retested on a 10-09 daily build.  

Application.ini:
[App]
Vendor=Mozilla
Name=B2G
Version=19.0a1
BuildID=20121009071002
ID={3c2e2abc-06d4-11e1-ac3b-374f68613e61}

[Gecko]
MinVersion=19.0a1
MaxVersion=19.0a1


Logcat:
10-10 09:12:51.165: I/Gecko(898): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:51.165: E/GeckoConsole(898): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:51.165: I/Gecko(898): *** AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 09:12:51.175: E/GeckoConsole(898): AUS:SVC gCanCheckForUpdates - able to check for updates
10-10 09:12:51.175: I/Gecko(898): *** AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:51.175: E/GeckoConsole(898): AUS:SVC Checker:checkForUpdates - sending request to: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:58.082: I/Gecko(898): *** AUS:SVC Checker:onProgress - 571/571
10-10 09:12:58.082: E/GeckoConsole(898): AUS:SVC Checker:onProgress - 571/571
10-10 09:12:58.092: I/Gecko(898): *** AUS:SVC Checker:onLoad - request completed downloading document
10-10 09:12:58.092: E/GeckoConsole(898): AUS:SVC Checker:onLoad - request completed downloading document
10-10 09:12:58.112: I/Gecko(898): *** AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:58.112: E/GeckoConsole(898): AUS:SVC Checker:getUpdateURL - update URL: http://update.boot2gecko.org/nightly/update.xml
10-10 09:12:58.112: I/Gecko(898): *** AUS:SVC Checker:onLoad - number of updates available: 1
10-10 09:12:58.112: E/GeckoConsole(898): AUS:SVC Checker:onLoad - number of updates available: 1
10-10 09:12:58.112: I/Gecko(898): *** AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 09:12:58.112: E/GeckoConsole(898): AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
10-10 09:12:58.122: I/Gecko(898): *** AUS:SVC gCanApplyUpdates - testing write access /data/local/update.test
10-10 09:12:58.122: E/GeckoConsole(898): AUS:SVC gCanApplyUpdates - testing write access /data/local/update.test
10-10 09:12:58.122: I/Gecko(898): *** AUS:SVC gCanApplyUpdates - able to apply updates
10-10 09:12:58.122: E/GeckoConsole(898): AUS:SVC gCanApplyUpdates - able to apply updates
10-10 09:12:58.132: I/Gecko(898): *** AUS:SVC UpdateService:_selectAndInstallUpdate - prompting because silent install is disabled
10-10 09:12:58.132: E/GeckoConsole(898): AUS:SVC UpdateService:_selectAndInstallUpdate - prompting because silent install is disabled

Comment 4

6 years ago
(In reply to Tony Chung [:tchung] from comment #3)
> Okay retested on a 10-09 daily build.  

Did it work? Looks like it did from the log..

Comment 5

6 years ago
Oh you should have received an 18 Gecko update. Jonathan - please make this your first priority today.
Assignee: nobody → jgriffin
Severity: normal → critical
blocking-basecamp: ? → +
Priority: -- → P1
(Assignee)

Comment 6

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #5)
> Oh you should have received an 18 Gecko update. Jonathan - please make this
> your first priority today.

See comment #3; the nightlies are now on gecko 19 due to bug 799843.
Shouldn't this be a duplicate of Bug 799843 at this point?
(Assignee)

Comment 8

6 years ago
(In reply to Marshall Culpepper [:marshall_law] from comment #7)
> Shouldn't this be a duplicate of Bug 799843 at this point?

Almost, but when bug 799843 is fixed, I'll need to update the update.xml again to specify v18.
(Assignee)

Comment 9

6 years ago
The nightly builds are back on aurora, so I've switched the update xml to specify 18.0a2 now (the same as is in application.ini).
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

6 years ago
(In reply to Alex Keybl [:akeybl] from comment #4)
> (In reply to Tony Chung [:tchung] from comment #3)
> > Okay retested on a 10-09 daily build.  
> 
> Did it work? Looks like it did from the log..

i forgot to reply to this.   the update from 10-10 did find 10-11.  but applying the update through the dialog UI uncovered bug 800804. 

Given bug 800804#c1 indicates the fix lives in bug 798948, i'll retest when its fixed.
status-firefox18: --- → fixed
status-firefox19: --- → fixed
You need to log in before you can comment on or make changes to this bug.