Closed Bug 800154 Opened 7 years ago Closed 7 years ago

Marionette needs log4moz.js, but it is no longer available

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox18 fixed)

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: jgriffin, Assigned: gps)

References

Details

Attachments

(2 files)

Marionette depends on log4moz.js, but this file is no longer available as of bug 799536.  According to gps, the best way to fix this is to pull in services/common.
This requires some larger-than-B2G build system magic and involves updating all the in-tree app .mk files. I should have a patch soon.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Component: Builds → Build Config
Product: Boot2Gecko → Core
I think this should do it. I'm still waiting on a local build to finish. Will submit a try once I've verified locally with app=browser.
Attachment #670166 - Flags: review?(mh+mozilla)
Comment on attachment 670166 [details] [diff] [review]
Refactor services/ integration with build system, v1

Review of attachment 670166 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +8246,5 @@
>  
> +dnl Build Common JS modules provided by services.
> +AC_SUBST(MOZ_SERVICES_COMMON)
> +if test -n "$MOZ_SERVICES_COMMON"; then
> +  AC_DEFINE(MOZ_SERVICES_COMMON)

Do you really need the AC_DEFINEs?
Attachment #670166 - Flags: review?(mh+mozilla) → review+
AC_DEFINEs are required because these variables are used as part of preprocessing (e.g. browser.js).

https://hg.mozilla.org/integration/mozilla-inbound/rev/16f4cd5455ab

This impacts B2G, so I /think/ this needs to go on Aurora.

jgriffin: what's the procedure for that?
Target Milestone: --- → mozilla19
(In reply to Gregory Szorc [:gps] from comment #5)
> AC_DEFINEs are required because these variables are used as part of
> preprocessing (e.g. browser.js).
> 
> https://hg.mozilla.org/integration/mozilla-inbound/rev/16f4cd5455ab
> 
> This impacts B2G, so I /think/ this needs to go on Aurora.
> 
> jgriffin: what's the procedure for that?

For changes that could potentially impact desktop Firefox like this, we need to request approval-mozilla-aurora-? on the patch, and fill in the details to the questions that appear.
Comment on attachment 670166 [details] [diff] [review]
Refactor services/ integration with build system, v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 799536
User impact if declined: Marionette won't work in B2G
Testing completed (on m-c, etc.): Builds will go orange if this broke anything in Firefox. Someone from B2G will verify this fixes B2G.
Risk to taking this patch (and alternatives if risky): If TBPL is green this should be low-risk. 
String or UUID changes made by this patch: None
Attachment #670166 - Flags: approval-mozilla-aurora?
(In reply to Gregory Szorc [:gps] from comment #7)
> Someone from B2G will verify this fixes B2G.

Hi, I can't still bring marionette back with this patch. In fact, neither can reverting bug 799536. Jonathan, do you have logs or something to identify the problem? I'll attach my log later.
Attached is mainly python backtrace with additional adb command prints when I interrupted Marionette on my own initiative. The Marionette keeps waiting for port forwarding setup but there is no response from Gecko.
(In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> (In reply to Gregory Szorc [:gps] from comment #7)
> > Someone from B2G will verify this fixes B2G.
> 
> Hi, I can't still bring marionette back with this patch. In fact, neither
> can reverting bug 799536. Jonathan, do you have logs or something to
> identify the problem? I'll attach my log later.

I have been successfully using Marionette today after locally reverting bug 799536.  Perhaps it's necessary to perform a clobber build for that change?
This patch requires a new configure and a |make -C services| to be realized.
(In reply to Jonathan Griffin (:jgriffin) from comment #10)
> (In reply to Vicamo Yang [:vicamo][:vyang] from comment #8)
> > (In reply to Gregory Szorc [:gps] from comment #7)
> > > Someone from B2G will verify this fixes B2G.
> > 
> > Hi, I can't still bring marionette back with this patch. In fact, neither
> > can reverting bug 799536. Jonathan, do you have logs or something to
> > identify the problem? I'll attach my log later.
> 
> I have been successfully using Marionette today after locally reverting bug
> 799536.  Perhaps it's necessary to perform a clobber build for that change?

I found that is another issue:

> gecko/build/autoconf/mozconfig2client-mk: 2: [: eng: unexpected operator

I'll open a new bug if necessary. Thanks :)
https://hg.mozilla.org/mozilla-central/rev/16f4cd5455ab
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 670166 [details] [diff] [review]
Refactor services/ integration with build system, v1

Please back out if you run into any issues.
Attachment #670166 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.