Holding down left mousebutton over link and dragging doesn't select

RESOLVED DUPLICATE of bug 79793

Status

()

Core
Selection
RESOLVED DUPLICATE of bug 79793
17 years ago
17 years ago

People

(Reporter: a_blip, Assigned: mjudge)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
When you hold down the right mousebutton over a link and drag, the whole link 
text should be selected. Instead, nothing happens. I can however select the link 
by starting in front of it.

Seen on both PPC build 2001050904 and Win32 build 2001051004.

Reproducible: Always
Steps to Reproduce:
1. Put mouse cursor over link.
2. Hold right mousebutton down.
3. Move mouse.

Actual Results:  Nothing happens.

Expected Results:  Entire link text should be selected.

Comment 1

17 years ago
I'm confused about this bug; it seems invalid to me.  Right-click should bring up 
a context menu; left-click should make the selection.  Is this a Windows-specific 
behavior you are requesting or am I missing something?
Summary: Holding down right mousbutton over link and dragging doesn't select → Holding down right mousebutton over link and dragging doesn't select

Comment 2

17 years ago
What we've seen in NS4:

1) Left click on link, hold mouse button, drag away, release button
   -> selects linked text
2) Right click on link, hold mouse button, drag away, release button
   -> pop-up menu appears immediately after right-click, so N/A in this case

I guess the reporter wants Mozilla to have the same behavior in (1) above.
(Reporter)

Comment 3

17 years ago
Sorry... I ment left mouse button... brain slip.
Summary: Holding down right mousebutton over link and dragging doesn't select → Holding down left mousebutton over link and dragging doesn't select

Comment 4

17 years ago
dupe of bug 79793

*** This bug has been marked as a duplicate of 79793 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.