[Cellular & Data] Doesn't work anymore

VERIFIED FIXED

Status

Firefox OS
General
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: John Shih, Assigned: kaze)

Tracking

({dogfood, smoketest, unagi})

unspecified
dogfood, smoketest, unagi
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

(Reporter)

Description

5 years ago
## Environment :
Otoro phone, build 2012-10-11
Build info: 
* "gaia" revision= beee2bf29e779b12306b16c2bc2785c1c22ede45
* "gecko" revision= c0ea0728044b2a5f9556ca988635140963cff037

## Repro :
1. Launch the settings
2. Open Data connection setting page
3. Set the APN and then turn on the Data Connections

## Expected:
* See the 3G icon on the status bar, and can load a website in browser

## Actual:
* Can't connect

## Note:
* It works fine with same steps in previous build
  e.g.
  2012-10-06 (nightly)
  gaia : 5f7dbe06490e6b52a356e033f52fb31c0fa0e2d0
  mozilla-central : b8aa67ed5e5dd9343da2692f206c406300b78085

Comment 1

5 years ago
Looks related to settings, 'ril.data.enabled' was never been set, not sure if it's gaia or gecko specific issue.

I/Gecko   (23726): -*- RadioInterfaceLayer: 'ril.data.enabled' is now undefined
I/Gecko   (23726): -*- RadioInterfaceLayer: No changes for ril.data.enabled flag. Nothing to do.

Comment 2

5 years ago
Gene, would you take a look at it?
Assignee: nobody → clian

Updated

5 years ago
blocking-basecamp: --- → ?
Priority: -- → P1
blocking-basecamp: ? → +
Keywords: dogfood
OS: Linux → All
Hardware: x86_64 → All
After some investigations, I think the root cause is more like a Gaia's bug due to the recent change by [1]. If I change the following codes:

  <label>
    <input type="checkbox" data-type="switch" name="ril.data.enabled"/>

back to:

  <label class="switch">
    <input type="checkbox" name="ril.data.enabled"/>

then everything works. That is, the RIL can receive a "true/false" setting value instead of "undefined". Note that, we also have the same issue for |ril.callwaiting.enabled| and |ril.callwaiting.enabled|.

Hi Kaze, could you please take a look on this issue? Tentatively, assign this to you. Please let me know if you think we need to have some corresponding changes in Gecko.

[1] https://github.com/mozilla-b2g/gaia/commit/ae7e8a532df111dc1826d312c32f63ee84750fba#apps/settings/index.html
Assignee: clian → kaze
Bug 799440 has been re-opend to address this issue.
Depends on: 799440
(In reply to Gene Lian [:gene] from comment #3)
> Hi Kaze, could you please take a look on this issue? Tentatively, assign
> this to you. Please let me know if you think we need to have some
> corresponding changes in Gecko.

I've reverted that change in Gaia, so this issue can be closed now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Duplicate of this bug: 800129
(Reporter)

Comment 7

5 years ago
verified on 
2012-10-12(master)
gaia : 2ab7bd25e21b7931b700731389ad433286a18945
mozilla-central : c96b188e4b7d480bdd897eb7b368afc91b8e6e5f
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

5 years ago
Thanks for the heads-up, I’ve submitted a new patch in bug 799440.
(In reply to Fabien Cazenave [:kaze] from comment #8)
> Thanks for the heads-up, I’ve submitted a new patch in bug 799440.

Thank you :) I reverted the whole patch because this issue was so urgent that I don't have the time to figure out the very problem.
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Keywords: smoketest, unagi
Doesn't work anymore on unagi, same steps

gecko-aurora: 0fd81b763e50
gaia: c8a7b4984fe39b6aa3dff9e42919afaa1af4eeb8
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
seems a different bug, I will open a new one.

Comment 12

5 years ago
Verified fixed the ability to browse via Cellular & Data network on Unagi with the following:

Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/406b86b4b515
Gaia: c5a8b6476f0dbc456061227a7801e56634683eb0
Build ID: 20130319070203
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.