Closed Bug 800332 Opened 8 years ago Closed 8 years ago

Regression: Unable to open remote tabs

Categories

(Firefox for Android :: General, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 19
Tracking Status
firefox19 --- verified

People

(Reporter: catlee, Assigned: bnicholson)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

I am unable to open any of the tabs listed under the home screen's "Synced Tabs" section, or from the sync tabs panel. I see all the tabs on my other devices listed, but clicking on them does nothing.
Product: Fennec → Firefox for Android
Duplicate of this bug: 800350
The regression window for this issue is:

good build:
2012/10/09

bad build 
2012/10/10

possible push-log:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dd61540f237c&tochange=ec10630b1a54
Looks like a possibility is Private Browsing (bug 582244), or bug 797075.

CC'ing Brian
Keywords: reproducible
Summary: Can't open sync tabs → Regression: Unable to open remote tabs
Regression from bug 797075 as remote tabs use Tab:Add
Blocks: 797075
Oops...looks like I missed some Tab:Add messages.
Assignee: nobody → bnicholson
Attachment #671513 - Flags: review?(mark.finkle)
Comment on attachment 671513 [details] [diff] [review]
Use loadUrl() to open remote tabs

Looks good. Can we add some simple tests for any of these things so we can catch more breakage? Any coverage would help.
Attachment #671513 - Flags: review?(mark.finkle) → review+
Flags: in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/4e9d97c92127
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.