If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Stop forcing -Werror on everybody

RESOLVED FIXED in mozilla19

Status

()

Core
WebRTC
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

Trunk
mozilla19
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Created attachment 670418 [details] [diff] [review]
Patch (v1)

This is regularly breaking people's builds.  WebRTC should switch to using FAIL_ON_WARNINGS at some point, but for now this unbreaks people's builds.
Attachment #670418 - Flags: review?(rjesup)

Comment 1

5 years ago
Comment on attachment 670418 [details] [diff] [review]
Patch (v1)

Review of attachment 670418 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/webrtc/signaling/signaling.gyp
@@ -216,1 @@
>              '-Wno-error=conversion'

You should probably take out these '-Wno-error=conversion' lines as well.

@@ -756,1 @@
>              '-Wno-error=conversion'

And here.
Comment on attachment 670418 [details] [diff] [review]
Patch (v1)

Review of attachment 670418 [details] [diff] [review]:
-----------------------------------------------------------------

With the changes to parts we don't use removed (to reduce update-from-upstream fun), r+

::: media/webrtc/trunk/build/common.gypi
@@ -1670,5 @@
>            }],
>            # TODO: Fix all warnings on chromeos too.
>            [ 'os_posix==1 and OS!="mac" and OS!="ios" and (clang!=1 or chromeos==1)', {
>              'cflags!': [
> -              '-Werror',

We purposely ignore cflags in mozmake.py, and only use cflags_mozilla

@@ +2793,5 @@
>            'GCC_INLINES_ARE_PRIVATE_EXTERN': 'YES',
>            'GCC_OBJC_CALL_CXX_CDTORS': 'YES',        # -fobjc-call-cxx-cdtors
>            'GCC_SYMBOLS_PRIVATE_EXTERN': 'YES',      # -fvisibility=hidden
>            'GCC_THREADSAFE_STATICS': 'NO',           # -fno-threadsafe-statics
> +          'GCC_TREAT_WARNINGS_AS_ERRORS': 'NO',    # -Werror

I don't believe we use the xcode_settings var when we build; that's used for xcode gyp output.

::: media/webrtc/trunk/build/nocompile.gypi
@@ +80,5 @@
>              'python',
>              '<(nocompile_driver)',
>              '4', # number of compilers to invoke in parallel.
>              '<(RULE_INPUT_PATH)',
> +            '-Wall -Wfatal-errors -I<(DEPTH)',

We don't use nocompile.gypi

::: media/webrtc/trunk/peerconnection_client.target.mk
@@ +45,5 @@
>  	'-DWTF_USE_DYNAMIC_ANNOTATIONS=1' \
>  	'-D_DEBUG'
>  
>  # Flags passed to all source files.
>  CFLAGS_Debug := \

We don't use peerconnection_client.target.mk
Attachment #670418 - Flags: review?(rjesup) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/bc8cbe29588d

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/bc8cbe29588d
Assignee: nobody → ehsan
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19

Updated

5 years ago
Whiteboard: [qa-]

Updated

5 years ago
Blocks: 808525
Duplicate of this bug: 839295
You need to log in before you can comment on or make changes to this bug.