[AccessFu] Web content in every tab but the first is no longer accessible

VERIFIED FIXED in Firefox 18

Status

()

defect
--
major
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: MarcoZ, Assigned: eeejay)

Tracking

({regression})

Trunk
mozilla19
ARM
Android
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18+ fixed)

Details

Attachments

(1 attachment)

Web content accessibility is broken in every tab except the first.

STR:
1. With Talkback on, run Nightly 19.0a1.
2. The start page is shown. Hit the menu button, Settings, About nightly.
3. A new tab opens with the About info. Slide your finger around the web content area.

Expected: You should hear items like the "Check for updates" or other links, or text spoken, as your finger touches them.
Actual: Nothing is heard. The only items accessible are the native widgets outside the web content area.

Suspect that this is a regression from the work to make out of process content accessible for b2g. This worked before I went on vacation on 9/17.
Additional info: I confirmed this also by opening a regular web page in the first tab, then tapping and holding a link and selecting "Open in new tab" from the popup menu. The web page in that second tab was not accessible, either.
Assignee: nobody → eitan
I noticed a few other regressions when writing this. Most prominent tab switching and the visual highlight not moving with the scroll.
Attachment #671002 - Flags: review?(dbolter)
Comment on attachment 671002 [details] [diff] [review]
Load script in to every new tab.

+    this.chromeWin.addEventListener('TabOpen', this);
Do you not also need to disable that event listener at some point? I don't see that in the patch.
(In reply to Eitan Isaacson [:eeejay] from comment #2)
> I noticed a few other regressions when writing this. Most prominent tab
> switching and the visual highlight not moving with the scroll.

Do you want to handle these in a follow-up patch to this bug, or a separate bug for those?
Comment on attachment 671002 [details] [diff] [review]
Load script in to every new tab.

Review of attachment 671002 [details] [diff] [review]:
-----------------------------------------------------------------

r=me, I think Marco is going to file bugs for other issues.
Attachment #671002 - Flags: review?(dbolter) → review+
(In reply to Marco Zehe (:MarcoZ) from comment #4)
> (In reply to Eitan Isaacson [:eeejay] from comment #2)
> > I noticed a few other regressions when writing this. Most prominent tab
> > switching and the visual highlight not moving with the scroll.
> 
> Do you want to handle these in a follow-up patch to this bug, or a separate
> bug for those?

I went ahead and filed bug 801671.
(In reply to Marco Zehe (:MarcoZ) from comment #3)
> Comment on attachment 671002 [details] [diff] [review]
> Load script in to every new tab.
> 
> +    this.chromeWin.addEventListener('TabOpen', this);
> Do you not also need to disable that event listener at some point? I don't
> see that in the patch.

Yup, we need to remove it too. I'll add a line for that.
https://hg.mozilla.org/mozilla-central/rev/e21bd5ae8cb2
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Comment on attachment 671002 [details] [diff] [review]
Load script in to every new tab.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): B2G work for content process separation.
User impact if declined: Every tab that is not the first will have inaccessible content. Blind users could no longer use tabbed browsing on their Android device.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None known.
String or UUID changes made by this patch: None.
Attachment #671002 - Flags: approval-mozilla-aurora?
Verified fixed in Fennec 19.0a1 2012-10-17.
Status: RESOLVED → VERIFIED
Attachment #671002 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.