Last Comment Bug 801080 - window.close will not close social panels
: window.close will not close social panels
Status: VERIFIED FIXED
[Fx17]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 19
Assigned To: Mark Hammond [:markh]
:
Mentors:
Depends on: 799592
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-12 13:24 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-12-04 15:58 PST (History)
11 users (show)
markh: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments
Set nsIDOMWindowUtils.allowScriptsToClose() plus tests (2.94 KB, patch)
2012-10-15 17:44 PDT, Mark Hammond [:markh]
felipc: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-12 13:24:44 PDT
+++ This bug was initially created as a clone of Bug #799592 +++

Morphing bug 799592 to cover the core fix. We'll need a social front-end fix to use the new API being introduced there.
Comment 1 Mark Hammond [:markh] 2012-10-15 17:44:46 PDT
Created attachment 671673 [details] [diff] [review]
Set nsIDOMWindowUtils.allowScriptsToClose() plus tests
Comment 2 Mark Hammond [:markh] 2012-10-15 19:54:15 PDT
there was a stray dump() in the test which I removed.

https://hg.mozilla.org/integration/mozilla-inbound/rev/bf5f5e60f37c
Comment 4 Ed Morley [:emorley] 2012-10-16 01:18:12 PDT
https://hg.mozilla.org/mozilla-central/rev/bf5f5e60f37c
Comment 5 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 15:19:48 PST
It looks like the patch landing includes tests. Is this correct?
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 15:58:40 PST
Thanks Mark. Verified fixed based on tests.

Note You need to log in before you can comment on or make changes to this bug.