If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Basketball live ticker does not work anymore

RESOLVED FIXED

Status

Tech Evangelism Graveyard
German
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

({regression})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
To reproduce:
1. Go to http://live.beko-bbl.de/ (live ticker from highest Germany Basketball level league)
2. Observe that the main area is empty and two scrollbars appear at the right side (the lower one cut off)

Note that sometimes the main area (below "Beko BBL", "ProA", "ProB") should actually be empty when the current matchday is over and the games of the next matchday are not visible yet. But the second (lower) scrollbar should never be visible.

This is a regression, it worked fine with the 2012-08-04 build and is broken in the 2012-08-05 (and newer) build.
Checkins: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=20fc34efd733&tochange=9453cf029b72
Unfortunately this range contains quite a lot of checkins, so this regression range probably needs some improvement or someone who can make an educated guess what bug might have caused this.
(Reporter)

Comment 1

5 years ago
(forgot to mention this :)
Expected Results:
In the main area of that web page the games of the current matchday should be visible.

Updated

5 years ago
Keywords: regressionwindow-wanted

Comment 2

5 years ago
The site used MooTools Version 1.2 as follows..
			<script src="js/mootools-1.2-core.js?v=8" type="text/javascript"></script>
			<script src="js/mootools-1.2-more.js?v=8" type="text/javascript"></script>

So, this is the site bug. 

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/aa100b9efcca
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803104127
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/87e7abe891a9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120803113827
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aa100b9efcca&tochange=87e7abe891a9
Assignee: nobody → general
Blocks: 789036
Status: UNCONFIRMED → NEW
tracking-firefox17: --- → ?
tracking-firefox18: --- → ?
tracking-firefox19: --- → ?
Component: General → JavaScript Engine
Ever confirmed: true

Updated

5 years ago
Assignee: general → german
Component: JavaScript Engine → German
Product: Core → Tech Evangelism
Version: Trunk → unspecified

Updated

5 years ago
tracking-firefox17: ? → ---
(Reporter)

Comment 3

5 years ago
I've contacted them and asked them to upgrade their MooTools version as the live ticker might break with Firefox 18.
Keywords: regressionwindow-wanted

Comment 4

5 years ago
Let's follow up in bug 789036 to make sure that we fix for FF18 again as necessary (bug 793781).
tracking-firefox18: ? → -
tracking-firefox19: ? → -

Comment 5

5 years ago
Juan - can you retest to see if we're still seeing this in FF18?
tracking-firefox18: - → ?
QA Contact: jbecerra
Created attachment 690481 [details]
Live sores Fx17.0.1 (works) vs Fx18.b3 (does not work)

The left hand side shows a fragment of the page in Fx17.0.1 where the live scores are displayed.

The right hand side shows the same page in Fx18b3 where this doesn't work.

Updated

5 years ago
status-firefox18: --- → affected

Comment 7

5 years ago
Thanks Juan. Outreach has already been performed - they can fix themselves after release, since this isn't a critical issue.
tracking-firefox18: ? → -
(Reporter)

Comment 8

5 years ago
I've reminded them again that their live ticker is still broken with the now released version of Firefox 18.
(Reporter)

Comment 9

5 years ago
They fixed this a few days ago by upgrading the MooTools version.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 10

5 years ago
Can conform a fix for it
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.