editor in twitter.com doesn't scroll at editing tweet and moving caret

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: masayuki, Assigned: JStagner)

Tracking

Details

Currently, we cannot see input text on the editor of twitter.com if the text is overflown from it.

twitter.com has changed their editor behavior. The editor is specified overflow:hidden;. According to the CSS spec, user shouldn't be scrollable such element by user's operation. However, other browsers can scroll editor even if it's specified overflow:hidden;.

The editor used to be resized its size by script when editing text is overflown from the editor. However, this behavior has been removed. This is the cause of this bug.

Only on m-c and Aurora, we landed patches which make users be able to scroll editor even if the editor is specified overflow:hidden;. However, not on beta yet. See bug 795785.

Comment 1

6 years ago
Joe - can you reach out to Twitter about this? See bug 795785 for more context, and feel free to shoot Masayuki/Ehsan an email for any clarification you may need.
Assignee: english-us → JStagner
(Assignee)

Comment 2

6 years ago
I emailed a couple of contacts at Twitter - will update after response.
(Assignee)

Comment 3

6 years ago
Twitter has accepted the bug and entered it into their tracking system/

Updated

5 years ago
Blocks: 904866
No longer blocks: 904866
I believe this is fixed. Overflow-y is set to auto. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.