The default bug view has changed. See this FAQ.

Kuma: Unnecessary errors - "The slug provided is not valid"

RESOLVED FIXED

Status

Mozilla Developer Network
Editing
P1
critical
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: ghost@ethertank.jp, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

I was edit following pages and tried save them.


https://developer.mozilla.org/ja/docs/HTML/Element/output
https://developer.mozilla.org/ja/docs/HTML/Element/dd
https://developer.mozilla.org/ja/docs/HTML/Element/dt
https://developer.mozilla.org/ja/docs/DOM/document
https://developer.mozilla.org/ja/docs/DOM/DOMError
https://developer.mozilla.org/ja/docs/DOM/DOMException
https://developer.mozilla.org/ja/docs/DOM/HTMLElement
https://developer.mozilla.org/ja/docs/DOM/DOMString
https://developer.mozilla.org/ja/docs/DOM/window.scrollTo
https://developer.mozilla.org/ja/docs/JavaScript_typed_arrays
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Object/seal
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/forEach
https://developer.mozilla.org/ja/docs/JavaScript/ECMAScript_6_support_in_Mozilla
https://developer.mozilla.org/ja/docs/Adding_feed_readers_to_Firefox
https://developer.mozilla.org/ja/docs/XUL/Property/browser.preferences


Actual results:

I can't save them. And a message is displayed like the following :

    "The slug provided is not valid"

...Probably have occurred in very many pages this issue.


Expected results:

I want to Save.
(Reporter)

Updated

5 years ago
Severity: normal → major
Priority: -- → P5

Comment 1

5 years ago
I and another user (taguchi-ch) can't save the following page. 

https://developer.mozilla.org/ja/docs/Mozilla/Boot_to_Gecko/Building_and_installing_Boot_to_Gecko

The same error message is shown.

Comment 2

5 years ago
Maybe this is linked to another bug found today : https://bugzilla.mozilla.org/show_bug.cgi?id=802558
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

5 years ago
Severity: major → critical
(Reporter)

Comment 3

5 years ago
I did come across this buggy behavior in October 2012.
Probably, I think there is a problem with the changes in September or October.

If the "translation source" is set, this problem does not occur.
Maybe there is some relevance.
Duplicate of this bug: 804006
Duplicate of this bug: 802558
Duplicate of this bug: 800801

Comment 7

5 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/25b079c3eb6afd55e1b51ae4a5e66cfb33c63c85
fix bug 801702 - Fix issue where slug field doesn't display

https://github.com/mozilla/kuma/commit/9d6efd67d136f93044bcb0b6d8398b092ccdb104
Merge pull request #679 from darkwing/slug-error-801702

fix bug 801702 - Fix issue where slug field doesn't display

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

5 years ago
I know that David Walsh did test in production server.

  https://developer.mozilla.org/ja/docs/Mozilla/Boot_to_Gecko/Building_and_installing_Firefox_OS$history
  https://developer.mozilla.org/ja/docs/DOM/DOMString$history
  
However, I still can't update those pages.
(Reporter)

Updated

4 years ago
Resolution: FIXED → WONTFIX
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 9

4 years ago
Created attachment 677991 [details]
Screenshot
(In reply to ghost@ethertank.jp from comment #8)
> However, I still can't update those pages.

I seem that the fixed revision has not landed on product server yet.
(Reporter)

Comment 11

4 years ago
(In reply to Tetsuharu OHZEKI [:saneyuki_s] from comment #10)

I think databases are not shared. 

https://developer.mozilla.org/en-US/docs/HTML
https://developer.allizom.org/en-US/docs/HTML
The update was pushed to our development snapshot site (developer-dev.allizom.org). It will go live on developer.mozilla.org later this week.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
Please reopen if you do not see the fix later this week, or if you do not see the fix even on developer-dev.
verified fixed stage https://developer.allizom.org/it/docs/HTML/HTML5
Status: RESOLVED → VERIFIED
Issue is still happening on this page:

https://developer.mozilla.org/fr/docs/HTML

...even though I cannot duplicate the issue on my local machine.  Grrr.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Annoyingly enough, all the Japanese docs cited in comment 1 work just fine.  It's just the French HTML page that is now causing an issue.
I tried other translations and they are all saveable without issue -- there's something specific to this French document that's causing an edge issue.
This is another issue, so I'm closing this and will open another ticket.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
David, do either of these bugs relate to bug 798809?
(Reporter)

Comment 20

4 years ago
(In reply to David Walsh :davidwalsh from comment #17)

I was able to update many pages. Thank you.
The following two messages are identical. I think this is another bug.

  "Another document with this slug already exists."
  "Un autre document avec cet identifiant d'URL existe déjà."

The same issue exists in the following pages.

https://developer.mozilla.org/ja/docs/HTML/Element/head
https://developer.mozilla.org/ja/docs/JavaScript/JavaScript_shells
https://developer.mozilla.org/zh-TW/docs/Gecko_DOM_%E5%8F%83%E8%80%83
Priority: P5 → P1
You need to log in before you can comment on or make changes to this bug.