Closed Bug 801716 Opened 7 years ago Closed 7 years ago

Thunderbird Permanent Orange: TEST-UNEXPECTED-FAIL | test_removeDataFromDomain.js | false == true

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

Details

(Keywords: regression)

Attachments

(1 file)

Since these were moved to toolkit, we've been seeing permanent test failures:

TEST-UNEXPECTED-FAIL | c:/talos-slave/test/build/xpcshell/tests/toolkit/forgetaboutsite/test/unit/test_removeDataFromDomain.js | false == true - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 451
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _do_check_eq :: line 545
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_eq :: line 566
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_true :: line 580
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/forgetaboutsite/test/unit/test_removeDataFromDomain.js :: check_visited :: line 76
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/forgetaboutsite/test/unit/test_removeDataFromDomain.js :: add_visit :: line 62
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/forgetaboutsite/test/unit/test_removeDataFromDomain.js :: test_history_cleared_with_direct_match :: line 318
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/forgetaboutsite/test/unit/test_removeDataFromDomain.js :: run_test :: line 628
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _execute_test :: line 315
JS frame :: -e :: <TOP_LEVEL> :: line 1
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

I think this is due to Thunderbird disabling places by default, I've got a fix in progress that I think should fix it for all tests.
For us this was a regression caused by bug 799229 moving the test to toolkit.
Blocks: 799229
Keywords: regression
Attached patch The fixSplinter Review
Simple solution of just ensuring that places history is enabled.
Attachment #671745 - Flags: review?(ehsan)
Attachment #671745 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/226cb9228a9e
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Comment on attachment 671745 [details] [diff] [review]
The fix

[Approval Request Comment]
This is regression caused by bug 799229 ; if bug 799229 is approved, this one needs to go with it.
Attachment #671745 - Flags: approval-mozilla-aurora?
Comment on attachment 671745 [details] [diff] [review]
The fix

approving since bug 799229 was approved.
Attachment #671745 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.