Closed Bug 799229 Opened 7 years ago Closed 7 years ago

Move the ForgetAboutSite module and the related tests from browser/components/privatebrowsing/ to toolkit

Categories

(Toolkit :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 + fixed
firefox19 + fixed

People

(Reporter: ehsan, Assigned: ehsan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

I'm in the process of shrinking down the size of the global PB component.  One ideal piece to be moved out is the ForgetAboutSite module, which can live inside toolkit.
Attached patch Patch (v1) (obsolete) — Splinter Review
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #669269 - Flags: review?(josh)
Comment on attachment 669269 [details] [diff] [review]
Patch (v1)

You're missing the new xpcshell.ini, and the Makefile for the new directory, and possibly other things.
Attachment #669269 - Flags: review?(josh) → review-
(In reply to Ehsan Akhgari [:ehsan] from comment #0)
> I'm in the process of shrinking down the size of the global PB component. 
> One ideal piece to be moved out is the ForgetAboutSite module, which can
> live inside toolkit.

You'll need module owner approval on the toolkit side for this.
Component: Private Browsing → General
OS: Mac OS X → All
Product: Firefox → Toolkit
Hardware: x86 → All
Summary: Move the ForgetAboutSite module and the related tests to toolkit → Move the ForgetAboutSite module and the related tests from browser/components/privatebrowsing/ to toolkit
Version: unspecified → Trunk
Attached patch Patch (v2)Splinter Review
Attachment #669269 - Attachment is obsolete: true
Attachment #669507 - Flags: review?(dtownsend+bugmail)
Comment on attachment 669507 [details] [diff] [review]
Patch (v2)

Review of attachment 669507 [details] [diff] [review]:
-----------------------------------------------------------------

Please just move it to toolkit/forgetaboutsite, the components/mozapps distinction is not useful anymore. Also add the new makefiles to toolkit/toolkit-makefiles.sh.
Attachment #669507 - Flags: review?(dtownsend+bugmail) → review+
Sure, will do.  Thanks for the review!
https://hg.mozilla.org/integration/mozilla-inbound/rev/24f4d7aeea8e
Target Milestone: --- → mozilla19
https://hg.mozilla.org/mozilla-central/rev/24f4d7aeea8e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 801716
Comment on attachment 669507 [details] [diff] [review]
Patch (v2)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): ForgetAboutSite.jsm is included from the wrong url in aurora (resource://gre/ instead of resource://) ; this was introduced by bug 774963 and bug 799126
User impact if declined: Firefox-on-xulrunner builds probably have private browsing broken.
Testing completed (on m-c, etc.): Landed on m-c a few days ago
Risk to taking this patch (and alternatives if risky): This should be low risk, as it only moves files around.
String or UUID changes made by this patch: None ; no l10n files moved either.
Attachment #669507 - Flags: approval-mozilla-aurora?
Yeah, this should be very low risk.
Attachment #669507 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.