Opening a minimized chat is broken

VERIFIED FIXED in Firefox 17

Status

()

Firefox
SocialAPI
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

Trunk
Firefox 19
x86_64
Windows 7
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox17+ verified, firefox18+ verified)

Details

(Whiteboard: [Fx17])

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Created attachment 671609 [details] [diff] [review]
Patch

When opening a chat window with the minimized option set to true, we set chatbox.minimized = true here: http://hg.mozilla.org/mozilla-central/annotate/cd3270dc35cc/browser/base/content/socialchat.xml#l328

However, this happens before we insert the element to the DOM, so the minimized getter/setter from the binding is not triggered, and this ends up as a simple property assignment. Also, since the property is defined, the binding doesn't overwrite it, so the toggle() function that changes cb.minimized doesn't work in this case.

By setting it afterwards the problem is fixed, and also the isActive property of that chat gets properly set. Note though that the socialFrameHide event will also be dispatched, so there's a change in behavior with this patch (which could be avoided if done in a different manner, but that sounds like the right behavior, so I'll let others chime in)
Attachment #671609 - Flags: review?(mixedpuppy)
Couldn't you just set the attribute instead? That way the panel opens as minimized, rather than opening normally and then being minimized.
(Assignee)

Comment 2

5 years ago
Yeah, that's what I was thinking as the alternate approach. Do you think it's better that way? The only problem of not using the setter is getting it out of sync with this opening code if we add more things to setter later. But that is likely not a problem as whoever writes the code will search for "minimized" and find this in the same file.
(Assignee)

Comment 3

5 years ago
Created attachment 671616 [details] [diff] [review]
Patch v2

approach suggested by gavin. Turns out setting isActive and dispatching socialFrameHide will happen anyways due to the DOMContentLoaded handler
Attachment #671616 - Flags: review?
Comment on attachment 671616 [details] [diff] [review]
Patch v2

Yeah, I think it's unlikely that we'll make the "minimized" setter any more complicated, and if we do we'll likely take this into account since it's hard to miss.
Attachment #671616 - Flags: review? → review+
(Assignee)

Comment 5

5 years ago
ok cool, i'm adding a test in a moment and another one might need to be changed
(Assignee)

Updated

5 years ago
Attachment #671609 - Attachment is obsolete: true
Attachment #671609 - Flags: review?(mixedpuppy)
(Assignee)

Comment 6

5 years ago
added a check for this in the existing chatwindow test. Other parts of the test did not need to be updated

https://hg.mozilla.org/integration/mozilla-inbound/rev/cc55531de631

Comment 7

5 years ago
https://hg.mozilla.org/mozilla-central/rev/cc55531de631
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
tracking-firefox17: --- → +
tracking-firefox18: --- → +
Whiteboard: [Fx17]
(Assignee)

Comment 8

5 years ago
Comment on attachment 671616 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature, part of Social API
User impact if declined: chats automatically opened by the worker will open full size and can't be minimized
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): very small on Firefox's side, but the provider needs to fix an issue that their chat layout is broken when open as minimized.
(If we do not take this patch we should take at least an alternate patch on the branches that allows chats to still be opened as full size but fix the fact that they can't be minimized)

String or UUID changes made by this patch: none
Attachment #671616 - Flags: approval-mozilla-beta?
Attachment #671616 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

5 years ago
Flags: in-testsuite+
Comment on attachment 671616 [details] [diff] [review]
Patch v2

a=me
Attachment #671616 - Flags: approval-mozilla-beta?
Attachment #671616 - Flags: approval-mozilla-beta+
Attachment #671616 - Flags: approval-mozilla-aurora?
Attachment #671616 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/5ad4b91f3710
https://hg.mozilla.org/releases/mozilla-beta/rev/3480249b8b76
status-firefox17: --- → fixed
status-firefox18: --- → fixed
Marking verified fixed since this landed with tests. Please add verifyme keyword if there's something you need QA to test.
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
status-firefox18: fixed → verified
You need to log in before you can comment on or make changes to this bug.