Closed Bug 801931 Opened 9 years ago Closed 9 years ago

[Settings] Create "Improve Firefox OS" settings page to hold crash reporting/telemetry settings

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: lco, Assigned: Margaret)

References

Details

Attachments

(1 file, 1 obsolete file)

This is based on the desire to add a settings page for crash reporting. (See pg. 8 of the spec: http://people.mozilla.com/~lco/Crash_Reporting_B2G/) I decided to put together all the settings regarding giving feedback to Mozilla.

This means that:

1. We need to create a new link in the main Settings page under Device. Let's put this link between "Media Storage" and "Help & Feedback". The name of the link will tentatively be "Improve Firefox OS"
2. We need a new icon for this link. I'll file a bug for Peter La.
3. We need to move the "Performance Data" setting out of "Device Information" into this new settings page.
4. We need to create the settings for Crash Reports, which I will file in a different bug.

I'll update the settings spec to reflect these changes. Stay tuned!
I'm going to pick this up next, since we need it for bug 801932.
Assignee: nobody → margaret.leibovic
Blocks: 801932
Summary: [Settings] As a user, I want to be able to control what information about my phone I share with Mozilla so that I can choose only the amount of sharing I'm comfortable with. → [Settings] Create "Improve Firefox OS" settings page to hold crash reporting/telemetry settings
Attached image screenshot (obsolete) —
This is ugly and doesn't match the mockup, but the functionality works :)

Larissa, how close is the page in that mockup to how you actually want things to look? It would be easier for me if it used UI pieces that we're already using (like radio buttons instead of those check marks).

Also, I basically just copy/pasted the telemetry setting from where it was before, just updating the string to match the new mockup. Maybe we can split polish for that setting into a separate bug, since it's already an existing piece of UI.
Attachment #676869 - Flags: feedback?(lco)
Duplicate of this bug: 801932
Thanks for sharing the screenshot!

(In reply to Margaret Leibovic [:margaret] from comment #2)
> Created attachment 676869 [details]
> screenshot
> 
> This is ugly and doesn't match the mockup, but the functionality works :)
> 
> Larissa, how close is the page in that mockup to how you actually want
> things to look? It would be easier for me if it used UI pieces that we're
> already using (like radio buttons instead of those check marks).

What you have is fine for now. It's what we're using in the Do Not Track setting as well.

I've been talking to Patryk about coming up with a standard building block for a small radio button list since what we're currently using isn't very effective at conveying that the choices are related, in my opinion. I don't know if we'll get it in for v1 though.


> 
> Also, I basically just copy/pasted the telemetry setting from where it was
> before, just updating the string to match the new mockup. Maybe we can split
> polish for that setting into a separate bug, since it's already an existing
> piece of UI.

Sure, that's fine. One thing we'll have to do is move that checkbox from the left to the right of the text, and to use the standard check button icon that we have: https://wiki.mozilla.org/images/9/9e/OWD_00_Switches.jpg
Marking + ; basically moving the blocking flag over as the dup bug is a blocker.
blocking-basecamp: --- → +
I tested to make sure this toggles the app.reportCrashes pref correctly on the gecko side.
Attachment #677186 - Flags: review?(kaze)
Attachment #676869 - Attachment is obsolete: true
Attachment #676869 - Flags: feedback?(lco)
Attachment #677186 - Flags: review?(kaze) → review+
https://github.com/mozilla-b2g/gaia/commit/ec8f31707e168d4654906e4a4e6b11234b5e7265
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Depends on: 807795
Blocks: 807805
Verified on Unagi Build ID: 2012121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.