Closed Bug 807805 Opened 7 years ago Closed 7 years ago

Remove app.reportCrashes from b2g.js now that we have crash reporter settings in the UI

Categories

(Firefox OS Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(firefox18 fixed)

RESOLVED FIXED
Tracking Status
firefox18 --- fixed

People

(Reporter: Margaret, Assigned: Margaret)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Now that we have crash reporter settings UI in Gaia (bug 801931), we can make the default setting "Ask me when a crash occurs".

app.reportCrashes will be toggled by the SettingsListener in settings.js.
Attachment #677564 - Flags: review?(fabrice)
Attachment #677564 - Flags: review?(fabrice) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/745af560fd80
Assignee: nobody → margaret.leibovic
Comment on attachment 677564 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): b2g crash reporter ui
User impact if declined: crash reporting will be automatic by default
Testing completed (on m-c, etc.): just pushed to inbound
Risk to taking this patch (and alternatives if risky): low-risk, default setting swtich
String or UUID changes made by this patch: n/a
Attachment #677564 - Flags: approval-mozilla-aurora?
Attachment #677564 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/745af560fd80
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.