Closed Bug 801935 Opened 7 years ago Closed 7 years ago

Don't unload wireless drivers

Categories

(Core :: DOM: Device Interfaces, defect, P1)

All
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: mwu, Assigned: mwu)

References

Details

(Keywords: unagi)

Attachments

(1 file)

Unloading wireless drivers can trigger bugs on improperly written drivers and is unnecessary on properly written drivers where taking the interface down powers down the hardware.
Attachment #671649 - Flags: review?(philipp)
This bug prevents the unagi from reconnecting after airplane mode or turning wifi off.
blocking-basecamp: --- → ?
Keywords: unagi
Attachment #671649 - Flags: review?(philipp) → review+
blocking-basecamp: ? → +
Priority: -- → P1
Can we land this on aurora as well? We need to spin the dogfooding candidate.
(In reply to Andreas Gal :gal from comment #3)
> Can we land this on aurora as well? We need to spin the dogfooding candidate.

Yup -

http://hg.mozilla.org/releases/mozilla-aurora/rev/4261b371ed95

I was waiting for blocking-basecamp+.
https://hg.mozilla.org/mozilla-central/rev/74816ae5dd43
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Duplicate of this bug: 776311
You need to log in before you can comment on or make changes to this bug.