Support sharing of the current page with a message

RESOLVED DUPLICATE of bug 818675

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 818675
6 years ago
6 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs-api-change])

Currently I can recommend a page but I'd like to be able to share it with a comment of why I think it's interesting.  This is a common scenario for many social networks.

Comment 1

6 years ago
This could also be resolved be allowing the sidebar to open when the user presses the share button. The sidebar could then display whatever fields are necessary to share on the target social networks.
(In reply to edA-qa mort-ora-y from comment #1)
> This could also be resolved be allowing the sidebar to open when the user
> presses the share button. The sidebar could then display whatever fields are
> necessary to share on the target social networks.

But the sidebar might already be open and already displaying content which interests the user.  Having the sidebar switch to a different UI then switch back seems a little jarring IMO.  I think we'd be better off with a "doorhanger" panel opening under the recommend button and loading provider content into that.
Sorry for the bug-spam.  This is a first cut at bugs that need (or potentially need) a change to the social api to be implemented appropriately.
Whiteboard: [needs-api-change]
Forward duping since work started in bug 818675.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818675
You need to log in before you can comment on or make changes to this bug.