Closed Bug 802152 Opened 7 years ago Closed 2 months ago

crash in nsA*String_internal::SetCapacity with abort message: "OOM: file e:\builds\moz2_slave\rel-m-beta-w32-bld\build\xpcom\string\src\nsTSubstring.cpp, line 533"

Categories

(Core :: XPCOM, defect, critical)

16 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash][tbird crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-d3eed749-2f3d-4347-b7ae-7ff6d2121016 .
============================================================= 

Seen while looking at the explosive report. https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%28char%20const*%20const%29%20|%20NS_DebugBreak_P%20|%20nsAString_internal%3A%3ASetCapacity%28unsigned%20int%29 links to the crashes which are all Windows.

A few of the comments mention upgrades, and one specifically mentions Java, so this may be related to users updating Java.

No addon correlations show for this signature for today - here are module correlations:

mozalloc_abort(char const* const) | NS_DebugBreak_P | nsIFrame::GetOffsetToCrossDoc(nsIFrame const*, int)|EXCEPTION_BREAKPOINT (90 crashes)
     56% (50/90) vs.   2% (1524/92192) nio.dll
     56% (50/90) vs.   2% (1524/92192) net.dll
     56% (50/90) vs.   2% (1537/92192) jp2native.dll
     56% (50/90) vs.   2% (1538/92192) deploy.dll
     56% (50/90) vs.   2% (1663/92192) zip.dll
     56% (50/90) vs.   2% (1666/92192) java.dll
     56% (50/90) vs.   2% (1666/92192) verify.dll
     56% (50/90) vs.   2% (1668/92192) jvm.dll
     56% (50/90) vs.   2% (1676/92192) npjp2.dll
    142% (128/90) vs.  97% (89509/92192) msvcr100.dll
    100% (90/90) vs.  58% (53620/92192) nssckbi.dll
    100% (90/90) vs.  59% (54777/92192) freebl3.dll
    100% (90/90) vs.  59% (54814/92192) nssdbm3.dll
    100% (90/90) vs.  59% (54822/92192) softokn3.dll
     98% (88/90) vs.  58% (53150/92192) shdocvw.dll
    100% (90/90) vs.  61% (56288/92192) feclient.dll
    100% (90/90) vs.  62% (56702/92192) winrnr.dll
    100% (90/90) vs.  63% (58315/92192) browsercomps.dll
    100% (90/90) vs.  64% (58913/92192) firefox.exe
    100% (90/90) vs.  64% (58970/92192) xpcom.dll
    100% (90/90) vs.  65% (59527/92192) dbghelp.dll
     99% (89/90) vs.  64% (58877/92192) rasadhlp.dll
     93% (84/90) vs.  60% (55486/92192) rsaenh.dll
     69% (62/90) vs.  36% (33488/92192) NapiNSP.dll
     79% (71/90) vs.  47% (43444/92192) t2embed.dll
     68% (61/90) vs.  36% (33308/92192) nlaapi.dll
     68% (61/90) vs.  36% (33499/92192) pnrpnsp.dll
     69% (62/90) vs.  39% (35833/92192) wship6.dll
     81% (73/90) vs.  52% (47639/92192) ntmarta.dll
    100% (90/90) vs.  71% (65578/92192) dnsapi.dll
     58% (52/90) vs.  30% (27431/92192) duser.dll
     69% (62/90) vs.  41% (37692/92192) WSHTCPIP.DLL
     63% (57/90) vs.  35% (32626/92192) DWrite.dll
    100% (90/90) vs.  73% (67126/92192) mswsock.dll
    100% (90/90) vs.  74% (67899/92192) wintrust.dll
     53% (48/90) vs.  27% (25235/92192) samlib.dll
     54% (49/90) vs.  29% (26315/92192) explorerframe.dll
     57% (51/90) vs.  31% (28377/92192) FWPUCLNT.DLL
     54% (49/90) vs.  29% (26330/92192) dui70.dll
     69% (62/90) vs.  43% (39692/92192) Wldap32.dll
     54% (49/90) vs.  29% (26437/92192) ntshrui.dll
     33% (30/90) vs.   9% (8112/92192) msvcr71.dll
     54% (49/90) vs.  30% (27662/92192) RpcRtRemote.dll
     51% (46/90) vs.  27% (24988/92192) linkinfo.dll
     50% (45/90) vs.  26% (23984/92192) cscapi.dll
     49% (44/90) vs.  25% (23117/92192) slc.dll
     39% (35/90) vs.  15% (13932/92192) WindowsCodecs.dll
     49% (44/90) vs.  26% (23536/92192) srvcli.dll
     54% (49/90) vs.  31% (28769/92192) cryptsp.dll
     89% (80/90) vs.  67% (61471/92192) apphelp.dll
     34% (31/90) vs.  14% (12982/92192) EhStorShell.dll
     96% (86/90) vs.  76% (69653/92192) icm32.dll
     58% (52/90) vs.  38% (35331/92192) dhcpcsvc.dll
     38% (34/90) vs.  20% (18712/92192) rtutils.dll
     61% (55/90) vs.  44% (40285/92192) mpr.dll
     34% (31/90) vs.  18% (16213/92192) mdnsNSP.dll
     36% (32/90) vs.  19% (17686/92192) rasapi32.dll
     36% (32/90) vs.  19% (17687/92192) rasman.dll
     44% (40/90) vs.  29% (26501/92192) dhcpcsvc6.DLL
     20% (18/90) vs.   5% (4759/92192) Wpc.dll
     20% (18/90) vs.   5% (4759/92192) wevtapi.dll
     20% (18/90) vs.   7% (6240/92192) netutils.dll
     13% (12/90) vs.   0% (284/92192) regutils.dll
     20% (18/90) vs.   7% (6672/92192) SensApi.dll
     19% (17/90) vs.   6% (5946/92192) samcli.dll
     81% (73/90) vs.  69% (63439/92192) urlmon.dll
     88% (79/90) vs.  76% (70017/92192) wininet.dll
     20% (18/90) vs.   9% (8477/92192) msvcr80.dll
     19% (17/90) vs.   8% (7719/92192) ieframe.dll
     69% (62/90) vs.  58% (53896/92192) propsys.dll
     34% (31/90) vs.  24% (22212/92192) oleacc.dll
     27% (24/90) vs.  16% (15051/92192) d3d10_1core.dll
     27% (24/90) vs.  16% (15051/92192) d3d10_1.dll
     36% (32/90) vs.  25% (23319/92192) msvcr90.dll
     13% (12/90) vs.   3% (2881/92192) MpOAV.dll
     27% (24/90) vs.  16% (15190/92192) dxgi.dll
     27% (24/90) vs.  17% (15667/92192) winsta.dll
     20% (18/90) vs.  11% (10118/92192) GdiPlus.dll
     14% (13/90) vs.   6% (5111/92192) actxprxy.dll
     17% (15/90) vs.   8% (7184/92192) cscui.dll
     17% (15/90) vs.   8% (7191/92192) cscdll.dll
     29% (26/90) vs.  20% (18459/92192) msvcp90.dll
     16% (14/90) vs.   7% (6294/92192) sxs.dll
     30% (27/90) vs.  21% (19631/92192) wtsapi32.dll
     16% (14/90) vs.   7% (6808/92192) ntdsapi.dll
     43% (39/90) vs.  35% (32430/92192) msacm32.drv
     77% (69/90) vs.  69% (63255/92192) iertutil.dll
     43% (39/90) vs.  35% (32528/92192) midimap.dll
     43% (39/90) vs.  35% (32695/92192) wdmaud.drv
     19% (17/90) vs.  11% (10270/92192) wshbth.dll
     49% (44/90) vs.  41% (38062/92192) netapi32.dll
     12% (11/90) vs.   5% (4264/92192) wkscli.dll
     11% (10/90) vs.   4% (3411/92192) PortableDeviceApi.dll
     22% (20/90) vs.  15% (13662/92192) d3d10.dll
     22% (20/90) vs.  15% (13662/92192) d3d10core.dll
     43% (39/90) vs.  36% (33143/92192) msacm32.dll
     11% (10/90) vs.   4% (3532/92192) IconCodecService.dll
     11% (10/90) vs.   4% (3568/92192) NetworkExplorer.dll
     22% (20/90) vs.  15% (13873/92192) d2d1.dll
     11% (10/90) vs.   4% (3781/92192) thumbcache.dll
     11% (10/90) vs.   4% (3883/92192) msvcp80.dll
     69% (62/90) vs.  62% (57175/92192) winnsi.dll
     69% (62/90) vs.  62% (57197/92192) IPHLPAPI.DLL
     10% (9/90) vs.   3% (2907/92192) EhStorAPI.dll
     24% (22/90) vs.  18% (16233/92192) WLIDNSP.DLL
     11% (10/90) vs.   4% (4018/92192) ntlanman.dll
      9% (8/90) vs.   2% (1970/92192) OFFICE.ODF
     11% (10/90) vs.   4% (4024/92192) davclnt.dll
     11% (10/90) vs.   4% (4029/92192) drprov.dll
      9% (8/90) vs.   2% (1990/92192) msxml6.dll
     10% (9/90) vs.   3% (3015/92192) SearchFolder.dll
     66% (59/90) vs.  59% (54251/92192) secur32.dll
      9% (8/90) vs.   2% (2016/92192) GROOVEEX.DLL
      9% (8/90) vs.   2% (2058/92192) GrooveIntlResource.dll
     10% (9/90) vs.   3% (3146/92192) StructuredQuery.dll
     32% (29/90) vs.  26% (23732/92192) lz32.dll
     10% (9/90) vs.   4% (3295/92192) devrtl.dll
     11% (10/90) vs.   5% (4339/92192) tiptsf.dll
     10% (9/90) vs.   4% (3323/92192) msls31.dll
      8% (7/90) vs.   2% (1535/92192) libGLESv2.dll
      8% (7/90) vs.   2% (1535/92192) libEGL.dll
      8% (7/90) vs.   2% (1536/92192) D3DCompiler_43.dll
      8% (7/90) vs.   2% (1542/92192) d3dx9_43.dll
     11% (10/90) vs.   5% (4616/92192) msi.dll
     10% (9/90) vs.   4% (3668/92192) xmllite.dll
     11% (10/90) vs.   5% (4703/92192) msv1_0.dll
     69% (62/90) vs.  63% (58001/92192) normaliz.dll
     78% (70/90) vs.  72% (66201/92192) lpk.dll
      9% (8/90) vs.   3% (2889/92192) msxml3.dll
     29% (26/90) vs.  23% (21442/92192) cryptui.dll
     10% (9/90) vs.   4% (4103/92192) ieproxy.dll
     69% (62/90) vs.  63% (58394/92192) MMDevAPI.dll
      9% (8/90) vs.   3% (3109/92192) igdumd32.dll
     31% (28/90) vs.  26% (23764/92192) wldap32.dll
     18% (16/90) vs.  13% (11656/92192) ksuser.dll
    100% (90/90) vs.  95% (87560/92192) mscms.dll


Frame 	Module 	Signature 	Source
0 	mozalloc.dll 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:23
1 	xul.dll 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:410
2 	xul.dll 	nsAString_internal::SetCapacity 	xpcom/string/src/nsTSubstring.cpp:533
3 	xul.dll 	nsXBLPrototypeHandler::Read 	content/xbl/src/nsXBLPrototypeHandler.cpp:908
4 	xul.dll 	nsXBLPrototypeBinding::Read 	content/xbl/src/nsXBLPrototypeBinding.cpp:1579
5 	xul.dll 	nsXBLDocumentInfo::ReadPrototypeBindings 	content/xbl/src/nsXBLDocumentInfo.cpp:648
6 	xul.dll 	nsXBLService::LoadBindingDocumentInfo 	content/xbl/src/nsXBLService.cpp:1007
7 	xul.dll 	nsXBLService::GetBinding 	content/xbl/src/nsXBLService.cpp:770
8 	xul.dll 	nsXBLService::GetBinding 	content/xbl/src/nsXBLService.cpp:743
9 	xul.dll 	nsXBLService::LoadBindings 	content/xbl/src/nsXBLService.cpp:505
10 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItemsInternal 	layout/base/nsCSSFrameConstructor.cpp:5156
11 	xul.dll 	nsCSSFrameConstructor::AddFrameConstructionItems 	layout/base/nsCSSFrameConstructor.cpp:5099
12 	xul.dll 	nsCSSFrameConstructor::ConstructFrame 	layout/base/nsCSSFrameConstructor.cpp:5038
13 	xul.dll 	nsCSSFrameConstructor::CreateAnonymousFrames 	layout/base/nsCSSFrameConstructor.cpp:3850
14 	xul.dll 	nsCSSFrameConstructor::BeginBuildingScrollFrame 	layout/base/nsCSSFrameConstructor.cpp:4230
15 	xul.dll 	nsCSSFrameConstructor::SetUpDocElementContainingBlock 	layout/base/nsCSSFrameConstructor.cpp:2753
16 	xul.dll 	nsCSSFrameConstructor::ConstructDocElementFrame 	layout/base/nsCSSFrameConstructor.cpp:2517
17 	xul.dll 	nsCSSFrameConstructor::ContentRangeInserted 	layout/base/nsCSSFrameConstructor.cpp:6935
18 	xul.dll 	PresShell::InitialReflow 	layout/base/nsPresShell.cpp:1653
19 	xul.dll 	nsContentSink::StartLayout 	content/base/src/nsContentSink.cpp:1176
20 	xul.dll 	nsHtml5TreeOpExecutor::StartLayout 	parser/html/nsHtml5TreeOpExecutor.cpp:743
21 	xul.dll 	nsHtml5TreeOperation::Perform 	parser/html/nsHtml5TreeOperation.cpp:631
22 	xul.dll 	nsHtml5TreeOpExecutor::RunFlushLoop 	parser/html/nsHtml5TreeOpExecutor.cpp:563
23 	nspr4.dll 	nspr4.dll@0x8d0f 	
24 	winmm.dll 	timeGetTime 	
25 	xul.dll 	nsHtml5ExecutorFlusher::Run 	parser/html/nsHtml5StreamParser.cpp:127
26 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
27 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
28 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:201
29 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:175
30 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
31 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:232
32 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:257
33 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3794
34 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3871
35 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3947
36 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:100
37 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
38 	kernel32.dll 	BaseThreadInitThunk 	
39 	ntdll.dll 	__RtlUserThreadStart 	
40 	ntdll.dll 	_RtlUserThreadStart
So far, this is still mostly happening on 16.0b6 but only very rarely on release versions.
Summary: crash in mozalloc_abort(char const* const) | NS_DebugBreak_P | → crash in nsAString_internal::SetCapacity
It's probably related to bug 776473 and bug 767343.

More reports also at: https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%28char+const*+const%29+|+NS_DebugBreak_P+|+nsACString_internal%3A%3ASetCapacity%28unsigned+int%29

(In reply to Marcia Knous [:marcia] from comment #0)
> No addon correlations show for this signature for today - here are module
> correlations:
> mozalloc_abort(char const* const) | NS_DebugBreak_P |
> nsIFrame::GetOffsetToCrossDoc(nsIFrame const*, int)|EXCEPTION_BREAKPOINT (90
> crashes)
That crash signature is unrelated to this one.
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsAString_internal::SetCapacity(unsigned int)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsAString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::SetCapacity(unsigned int)]
OS: Windows NT → Windows 7
Summary: crash in nsAString_internal::SetCapacity → crash in nsA*String_internal::SetCapacity with abort message: "OOM: file e:\builds\moz2_slave\rel-m-beta-w32-bld\build\xpcom\string\src\nsTSubstring.cpp, line 533"
Whiteboard: [startupcrash]
Scoobidiver, 
Any correlations for Thunderbird?  
In TB16 it's currently #1 crash, and TB17 is #28.
Whiteboard: [startupcrash] → [startupcrash][tbird crash]
Duplicate of this bug: 837438
Blocks: 837438
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsAString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::SetCapacity(unsigned int)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsAString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak_P | nsACString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_De…
Crash Signature: NS_DebugBreak] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int)] → NS_DebugBreak] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int)]
This may have something to do with cache files.
Try to remove them. This helped in my case.
Depends on: 859247
Crash Signature: NS_DebugBreak] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int)] → NS_DebugBreak] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const* const) | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int)] [@ mozalloc_abort(char const*) …
OS: Windows 7 → All
Hardware: x86 → All
Whiteboard: [startupcrash][tbird crash] → [snative-crash][tbird crash]
Whiteboard: [snative-crash][tbird crash] → [native-crash][tbird crash]
Crash Signature: | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int) ] → | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int) ] [@ mozalloc_abort(char const*) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int) ]
Blocks: 837835
(In reply to Dmitry Dartz from comment #5)
> This may have something to do with cache files.
> Try to remove them. This helped in my case.

which cache files/directories?
Flags: needinfo?(dmda)
(In reply to Wayne Mery (:wsmwk) from comment #6)
> which cache files/directories?

I mean files and subdirectories in mozilla Profiles/Cache, Profiles/safebrowsing and Profiles/startupCache directories. They had some content left from a previous version of mozilla. Seems they affect mozilla in such a dramatic way described in this issue.
At least I had exactly the same sympthoms and problem has gone after I removed CACHE.
Flags: needinfo?(dmda)
Crash Signature: | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int) ] [@ mozalloc_abort(char const*) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int) ] → | NS_DebugBreak | nsAString_internal::SetCapacity(unsigned int) ] [@ mozalloc_abort(char const*) | NS_DebugBreak | nsACString_internal::SetCapacity(unsigned int) ] [@ mozalloc_abort | NS_DebugBreak_P | nsAString_internal::SetCapacity] [@ mozalloc_abor…

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.