Reuse a11y hover event for a11y focus event

VERIFIED FIXED in Firefox 18

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: eeejay, Assigned: eeejay)

Tracking

unspecified
Firefox 19
x86_64
Linux
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
On Jellybean, TalkBack listens for hover enter events, and then uses them to put the accessibility focus on the hovered item. Right now we interrogate the js layer for the current a11y focus since we don't distinguish between explore by touch and a11y focus.

Going back to the js layer to re-send the previous hover event as an a11y focus event is an anti-pattern. In this patch we simply cache the event and reuse it as an a11y focus event.
(Assignee)

Comment 1

5 years ago
Created attachment 671944 [details] [diff] [review]
Reuse hover enter events for accessibility focus events.
Attachment #671944 - Flags: review?(blassey.bugs)
(Assignee)

Updated

5 years ago
Blocks: 802273
Attachment #671944 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/c8286a2f35ab
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19

Comment 4

5 years ago
Verified in the 2012-10-20 nightly build.
Status: RESOLVED → VERIFIED

Comment 5

5 years ago
Comment on attachment 671944 [details] [diff] [review]
Reuse hover enter events for accessibility focus events.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial implementation proving to be inaccurate when recognizing touch/hover events.
User impact if declined: Irregularly inaccurate accessibility focus and potentially wrong clicks executed by TalkBack.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None. This bug must be taken together with bug 802273.
Attachment #671944 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #671944 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Updated

5 years ago
status-firefox18: --- → fixed
You need to log in before you can comment on or make changes to this bug.