Closed Bug 802273 Opened 7 years ago Closed 7 years ago

[AccessFu] Remove presentLastPivot antipattern

Categories

(Core :: Disability Access APIs, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla19
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

Details

Attachments

(1 file)

As described in bug 802270, we should no longer interrogate AccessFu for our a new a11y focus event after a hover.
Depends on: 802270
Comment on attachment 671945 [details] [diff] [review]
Remove present last pivot code. It is an antipattern.

Review of attachment 671945 [details] [diff] [review]:
-----------------------------------------------------------------

r=me dependent on bug 802270 of course. I guess it makes sense to reuse the hover event since you normalize in the android presenter.
Attachment #671945 - Flags: review?(dbolter) → review+
https://hg.mozilla.org/mozilla-central/rev/f2b0c3499456
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Verified in the 2012-10-20 build, together with bug 802270. Believe it's a bit more responsive and more reliable in recognizing touch and dragging gestures within web content.
Status: RESOLVED → VERIFIED
Comment on attachment 671945 [details] [diff] [review]
Remove present last pivot code. It is an antipattern.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Initial Explore By Touch implementation.
User impact if declined: Occasional incorrect accessibility focus, causing clicks in wrong spots when Talkback executes taps simulations.
Testing completed (on m-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): None.
String or UUID changes made by this patch: None. Must be taken together with bug 802270.
Attachment #671945 - Flags: approval-mozilla-aurora?
Comment on attachment 671945 [details] [diff] [review]
Remove present last pivot code. It is an antipattern.

Approving for Aurora as the user impact is not something we want our accessibility users to end up with
Attachment #671945 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.