Closed Bug 802566 Opened 8 years ago Closed 8 years ago

JavaScript Error occurs when trying to poseResult in a web activity

Categories

(Firefox OS Graveyard :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 801546
blocking-basecamp +

People

(Reporter: jj.evelyn, Assigned: airpingu)

Details

After calling activity.postResult(result), the following JavaScript error occurs:

E/GeckoConsole(  106): [JavaScript Error: "caller is undefined" {file: "resource://gre/modules/ActivitiesService.jsm" line: 299}]

and thus the activity fails to go back to caller.
Ah, dup.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802108
Marking as a blocker since dupe is a blocker.
blocking-basecamp: ? → +
Sorry but I don't think this is a duplicate if bug 802108
It still happens on my latest build:

Gaia master: 7de48142a33dd8bb78bd0cd2bd24282d7378c179 (Thu Oct 18 20:29:01 2012 -0700)
Gecko: 43b9264e47c614c48a23c3efa2d8adefa7d5a4fb (Thu Oct 18 21:28:57 2012 -0400)

STR:
1. enable SIM card pin in Settings app
2. reboot phone
3. when 'Enter SIM PIN' sheet shows, enter correct SIM PIN, and click OK
4. the JavaScript Error occurs in the logcat.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Let me take this one!
Assignee: nobody → clian
Might be the same issue to Bug 801546.
Yep Gene, you're right.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801546
You need to log in before you can comment on or make changes to this bug.