[gallery] [camera] Not able to add a photo to a contact from contact details

VERIFIED FIXED

Status

defect
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: carlosmartinez, Assigned: fabrice)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

Tested in otoro with:

Gecko-1ec4bde
Gaia-2b4f33c

STR
1-Open contacts app
2-Create a new contact
3-Tap in the add image zone
4-Try to add a photo from Gallery or Camera

Expected result --> You´re able to add a photo from camera (camera app is opened to take a picture and then is associated to the contact) or from gallery (gallery is opened and you can select an image)

Actual result --> Gallery crashes and camera is not opened, you get a white screen.
blocking-basecamp: --- → ?
Tim,

Could this be caused by the recent activities changes to close the handler app?
cc'ing Fabrice also since it sounds like this is activities-related.
The Contacts->Gallery image picking works for me with https://releases.mozilla.com/b2g/latest/otoro_2012-10-15_eng.zip

Contacts->Camera doesn't work for me... the camera crashes when I try it.

So maybe this isn't activities related.

Updated

7 years ago
blocking-basecamp: ? → +
Fabrice this is always the same bug that Andrea and Gene has tried to fix. Assigning to you. Feel free to redirect.
Assignee: nobody → fabrice

Comment 5

7 years ago
With the following build:
 * Gaia: f08661d 
  * Gecko: 83ade38

the result is the following:
STR
1-Open contacts app
2-Create a new contact
3-Tap in the add image zone
4-Try to add a photo from Gallery or Camera

Expected result --> You´re able to add a photo from camera (camera app is opened to take a picture and then is associated to the contact) or from gallery (gallery is opened and you can select an image)

Actual result --> Camara  crashes and gallery you can select a photo and when you tap on crop the end-user is redirect to the gallery and not to the contact app
Assignee

Comment 6

7 years ago
Posted patch patchSplinter Review
A message name mismatch lead to an undefined |caller| and subsequent crashes.
Attachment #673407 - Flags: review?(jones.chris.g)
Attachment #673407 - Flags: review?(jones.chris.g) → review+
https://hg.mozilla.org/mozilla-central/rev/81c2eb10eb82
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee

Updated

7 years ago
Duplicate of this bug: 802566
Duplicate of this bug: 803016
OS: Windows 7 → Gonk
Hardware: x86_64 → ARM

Comment 12

7 years ago
Tested in daily 10/22/2012 on Unagi.   

gecko - 471232068fc202ba54b12eaf5b7de70aef4a079e 
gaia - cf533e66c4c589478f5addc53cab2d9a4853402b

Works.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.