Last Comment Bug 802667 - configure new buildbot masters for use with android on pandas
: configure new buildbot masters for use with android on pandas
Status: RESOLVED FIXED
[reit-panda]
:
Product: Release Engineering
Classification: Other
Component: Platform Support (show other bugs)
: other
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Kim Moir [:kmoir]
: Chris Cooper [:coop]
Mentors:
Depends on: 805852
Blocks: 778733 799698
  Show dependency treegraph
 
Reported: 2012-10-17 09:29 PDT by Kim Moir [:kmoir]
Modified: 2013-08-12 21:55 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to to enable new buildbot masters for pandas (3.01 KB, patch)
2012-10-26 07:08 PDT, Kim Moir [:kmoir]
no flags Details | Diff | Splinter Review
allow new buildbot masters for pandas to puppetize (3.24 KB, patch)
2012-10-26 07:15 PDT, Kim Moir [:kmoir]
bugspam.Callek: review+
kmoir: checked‑in+
Details | Diff | Splinter Review
patch to add new buildbot masters (12.78 KB, patch)
2012-10-26 13:47 PDT, Kim Moir [:kmoir]
bugspam.Callek: review+
kmoir: checked‑in+
Details | Diff | Splinter Review
patch for puppet-manifests (1.93 KB, patch)
2012-11-05 15:09 PST, Kim Moir [:kmoir]
bugspam.Callek: review+
kmoir: checked‑in+
Details | Diff | Splinter Review
[configs] add panda_android to .template (440 bytes, patch)
2012-11-06 22:08 PST, Justin Wood (:Callek)
no flags Details | Diff | Splinter Review
limit platforms on bm29 to android (882 bytes, patch)
2012-11-13 08:04 PST, Kim Moir [:kmoir]
bugspam.Callek: review+
Details | Diff | Splinter Review
patch to limit to android for all panda masters (7.44 KB, patch)
2012-11-14 05:48 PST, Kim Moir [:kmoir]
kmoir: checked‑in+
Details | Diff | Splinter Review

Description Kim Moir [:kmoir] 2012-10-17 09:29:18 PDT
In bug, 7999923 relops set up new buildbot masters for android/b2g.  This bug will track the releng side of configuring the new masters for android on pandas.
Comment 1 Kim Moir [:kmoir] 2012-10-26 07:08:36 PDT
Created attachment 675546 [details] [diff] [review]
patch to to enable new buildbot masters for pandas
Comment 2 Kim Moir [:kmoir] 2012-10-26 07:15:23 PDT
Created attachment 675548 [details] [diff] [review]
allow new buildbot masters for pandas to puppetize

fixed whitespace
Comment 3 Kim Moir [:kmoir] 2012-10-26 13:47:12 PDT
Created attachment 675679 [details] [diff] [review]
patch to add new buildbot masters

in disabled state, I'll enable them as needed
Comment 4 Nick Thomas [:nthomas] 2012-10-29 23:30:09 PDT
FYI, the nagios downtime on these masters got extended another couple of days.
Comment 5 Kim Moir [:kmoir] 2012-10-31 13:45:55 PDT
Comment on attachment 675679 [details] [diff] [review]
patch to add new buildbot masters

They are are disabled by default so we could land these in advance of them all being needed in production.
Comment 6 Justin Wood (:Callek) 2012-10-31 14:18:30 PDT
Comment on attachment 675679 [details] [diff] [review]
patch to add new buildbot masters

>diff --git a/buildfarm/maintenance/production-masters.json b/buildfarm/maintenance/production-masters.json
>--- a/buildfarm/maintenance/production-masters.json
>+++ b/buildfarm/maintenance/production-masters.json
>+  {
>+    "limit_fx_platforms": [
>+        "android",
>+        "android-armv6",
>+        "android-noion"
>+    ],


I merely skimmed, and looks good at a skim, however do we want to change this, for specific "panda", or whatever here (note that coop found out earlier that listing a platform here that is not also in the configs does break stuff - and is why the scl1 panda master we already have in here is showing android as well)
Comment 7 Kim Moir [:kmoir] 2012-10-31 14:58:50 PDT
I don't know, right now we are just running tests for android on panda boards.  My other changes in bug 803248 just run tests on another class of slaves, panda_android not a new platform. What are your thoughts coop?
Comment 8 Phil Ringnalda (:philor, back in August) 2012-10-31 23:48:04 PDT
Nagios downtime extended to 9am Eastern Monday, because omg they spew, hard and fast and loud, when it expires.
Comment 9 Kim Moir [:kmoir] 2012-11-01 12:24:03 PDT
Comment on attachment 675679 [details] [diff] [review]
patch to add new buildbot masters

I talked with coop today and he said that 

"limit_fx_platforms": [
        "android",
        "android-armv6",
        "android-noion"
    ],

is fine for now until we start running specific panda android builds on panda boards.
Comment 10 Kim Moir [:kmoir] 2012-11-05 15:09:16 PST
Created attachment 678493 [details] [diff] [review]
patch for puppet-manifests
Comment 11 Kim Moir [:kmoir] 2012-11-05 15:22:53 PST
Comment on attachment 678493 [details] [diff] [review]
patch for puppet-manifests

and puppet masters updated
Comment 12 Justin Wood (:Callek) 2012-11-06 22:08:26 PST
Created attachment 679048 [details] [diff] [review]
[configs] add panda_android to .template

I saw preprod failing, and I suspect the absense in here is the overall root cause. I manually added this on preprod as well, but I forget how its updated there.
Comment 13 Kim Moir [:kmoir] 2012-11-07 06:35:24 PST
Comment on attachment 679048 [details] [diff] [review]
[configs] add panda_android to .template

I already see this in production from my earlier patch

http://hg.mozilla.org/build/buildbot-configs/rev/ceec281725e8
Comment 14 Kim Moir [:kmoir] 2012-11-13 08:04:27 PST
Created attachment 681045 [details] [diff] [review]
limit platforms on bm29 to android
Comment 15 Justin Wood (:Callek) 2012-11-13 15:57:20 PST
Comment on attachment 681045 [details] [diff] [review]
limit platforms on bm29 to android

rs+ if you decide to do this to other panda-masters already in the .json
Comment 16 Kim Moir [:kmoir] 2012-11-14 05:48:36 PST
Created attachment 681458 [details] [diff] [review]
patch to limit to android for all panda masters
Comment 17 Justin Wood (:Callek) 2012-12-13 17:31:30 PST
Kim -- this one resolveable?
Comment 18 Kim Moir [:kmoir] 2012-12-14 05:32:26 PST
sure

Note You need to log in before you can comment on or make changes to this bug.