google account "setup" never completes

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: gal, Assigned: squib)

Tracking

unspecified
B2G C2 (20nov-10dec)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

(Reporter)

Description

6 years ago
I added my gmail account and the spinner screen appears and sticks around for minutes and never completes. My account has hundred thousands of emails.

In any case, this screen must not exist. There should be no blocking email setup screen like that. Can you explain what happens during this pause? All that should happen here is store account and password, maybe create some empty databases, and then kick off the first email sync.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → +
Priority: -- → P1
(In reply to Andreas Gal :gal from comment #0)
> In any case, this screen must not exist. There should be no blocking email
> setup screen like that. Can you explain what happens during this pause? All
> that should happen here is store account and password, maybe create some
> empty databases, and then kick off the first email sync.

No mail synchronization is happening, something is just busted.

Autoconfiguration runs to figure out what type of mail server and hosts to use.  In the case of gmail.com, we will load gaia-repo/apps/email/autoconfig/gmail.com from disk and it will tell us to use ActiveSync with m.google.com.  We then run ActiveSync autodiscovery against that URL to verify account credentials.  We will then synchronize the folder list and once that completes, the account is fully created.

An "adb logcat" or secret debug mode log (https://wiki.mozilla.org/Gaia/Email/SecretDebugMode) can provide extra info.

Comment 2

6 years ago
Is bug 802301 a dup of this issue?

I'm seeing this as well on for any mail setup I do.  Happy to get better debug data if someone can point me at some steps.
(Assignee)

Comment 3

6 years ago
This works for me, and it only takes a couple of seconds before we've verified all the account details. (It's hard to tell exactly how long it takes because my B2G doesn't like to update the UI in real-time anymore.)

Is this an actual @gmail.com account, or are you using Google Apps?

Updated

6 years ago
Duplicate of this bug: 802301
I wonder if this may be a duplicate of bug 804765?
The reason I ask, is because I have a gmail account that has a lot of emails; the load more feature isn't implemented yet + a gmail account only downloads so much email in the inbox.
(Assignee)

Comment 8

6 years ago
(In reply to Naoki Hirata :nhirata from comment #7)
> The reason I ask, is because I have a gmail account that has a lot of
> emails; the load more feature isn't implemented yet + a gmail account only
> downloads so much email in the inbox.

Change the filter range for your account in the settings. ActiveSync doesn't support the "load more" paradigm we use in IMAP.

Updated

6 years ago
Priority: P1 → --

Comment 9

6 years ago
What is the status in here? Shouldn't this be a blocker?

Comment 10

6 years ago
This is a blocker and we're trying to understand the root problem in this bug.
qawanted : need to check out comment 8, and changing the filter range to see if it's the cause of the issue.
Keywords: qawanted
(In reply to Naoki Hirata :nhirata from comment #11)
> qawanted : need to check out comment 8, and changing the filter range to see
> if it's the cause of the issue.

It's not the cause of the issue.  As I understand Andreas' comment, he tried to create the account, and got stuck at the account creation spinner screen. *no mail synchronization occurs during this screen*.  Jim's comment 8 was responding to your comment 7, but is not related to this bug.

What is most useful is an adb logcat from a gmail account setup that fails, at least one where the preference "browser.dom.window.dump.enabled" is true.

Updated

6 years ago
Priority: -- → P1
Assignee: nobody → squibblyflabbetydoo
Ok, then it sounds like a problem with authentication?  I'll set this to need additional info to ping andreas for the info in comment 12.
Flags: needinfo?(gal)
Keywords: qawanted
Milestoning for C2 (deadline of 12/10), as this meets the criteria of "remaining P1 bugs not already milestoned for C1".
Target Milestone: --- → B2G C2 (20nov-10dec)
(Assignee)

Comment 15

6 years ago
We've just switched Gmail to use IMAP instead of ActiveSync. Since the setup process is now very different (and works for me), I'm going to close this bug. However, there will be some other improvements to Gmail setup in bug 810031, so keep an eye on that if things still don't work.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(gal)
Resolution: --- → FIXED

Comment 16

6 years ago
Verified on Unagi Build ID: 2012121231070201
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.