Last Comment Bug 802784 - possible to have two panels open at once
: possible to have two panels open at once
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 19
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-17 13:06 PDT by Shane Caraveo (:mixedpuppy)
Modified: 2012-12-14 13:35 PST (History)
6 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified
verified


Attachments
Patch (1.84 KB, patch)
2012-10-17 13:59 PDT, Jared Wein [:jaws] (please needinfo? me)
mixedpuppy: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Shane Caraveo (:mixedpuppy) 2012-10-17 13:06:10 PDT
If you open a status panel, then mouse over the sidebar which can open a flyout, you end up with two panels open at the same time.
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-10-17 13:59:58 PDT
Created attachment 672513 [details] [diff] [review]
Patch

This is a simple fix.

A lower level fix in popup widget code isn't probably something we could uplift, because it could introduce regressions with popups that have nested menupopups.
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-10-21 23:59:42 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/d0daa527d1b4
Comment 3 Ryan VanderMeulen [:RyanVM] 2012-10-22 19:06:23 PDT
https://hg.mozilla.org/mozilla-central/rev/d0daa527d1b4

Should this have a test?
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-29 18:05:21 PDT
Comment on attachment 672513 [details] [diff] [review]
Patch

[Triage Comment]
a=me for 17/18
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-29 23:39:29 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/f5f5541d3a9f
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-10-30 11:53:16 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/d8c14f8f384e
Comment 7 Mihai Morar, (:MihaiMorar) 2012-12-14 04:45:25 PST
I couldn't reproduce this issue on FF 17 and FF 18b4 on Windows 7 x64 and Ubuntu x86.
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-14 12:58:31 PST
Thanks Mario, can you try the latest 19.0a2 Aurora build?
Comment 9 Mihai Morar, (:MihaiMorar) 2012-12-14 13:35:24 PST
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20121214 Firefox/19.0 (20121214042017) WFM as FF17 and FF18b4 did.

Note You need to log in before you can comment on or make changes to this bug.