sidebar width not saved at shutdown

RESOLVED FIXED in Firefox 17

Status

defect
RESOLVED FIXED
7 years ago
4 months ago

People

(Reporter: em, Assigned: markh)

Tracking

19 Branch
Firefox 19
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 verified, firefox18 verified)

Details

Attachments

(1 attachment)

Reporter

Description

7 years ago
The width of the social sidebar is not being saved when the user exits FireFox. I would expect on reload the sidebar to have the same size it did when I exiting. 

If you open/close the sidebar, or enable/disable the provider, without exiting Firefox it does retain its size.
Assignee

Comment 1

7 years ago
Adds persist="width" to the social-sidebar-box.
Attachment #673019 - Flags: review?(jaws)
Attachment #673019 - Flags: review?(jaws) → review+
Assignee

Comment 2

7 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/db6173f6dd09
Assignee: nobody → mhammond
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: in-testsuite-
OS: Linux → All
Hardware: x86 → All
Whiteboard: [verifyme]
https://hg.mozilla.org/mozilla-central/rev/db6173f6dd09
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Keywords: verifyme
Whiteboard: [verifyme]
Comment on attachment 673019 [details] [diff] [review]
Add persist="width" attribute

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature - social
User impact if declined: if the sidebar was resized the size is not persisted
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): minimal
String or UUID changes made by this patch: none
Attachment #673019 - Flags: approval-mozilla-beta?
Attachment #673019 - Flags: approval-mozilla-aurora?
Attachment #673019 - Flags: approval-mozilla-beta?
Attachment #673019 - Flags: approval-mozilla-beta+
Attachment #673019 - Flags: approval-mozilla-aurora?
Attachment #673019 - Flags: approval-mozilla-aurora+
This has approval for branch uplift, please land asap.
Verified on Firefox 17 beta 5 that - the sidebar width is the same when the user exits Firefox willingly (File menu -> Exit/"x button" or restart) or unexpectedly (by killing Firefox or after a crash).

Verified that the sidebar width is the same after exiting/opening Firefox on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/17.0 Firefox/17.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Verified as fixed on Firefox 18 beta 1 - the sidebar width is saved at shutdown.

Verified on Windows 8, Ubuntu 12.04 and Mac OS X 10.7: 
Mozilla/5.0 (Windows NT 6.2; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0
Mozilla/5.0 (X11; Linux i686; rv:18.0) Gecko/18.0 Firefox/18.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0
mass remove verifyme requests greater than 4 months old
Keywords: verifyme

Updated

4 months ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.