System Slows Down with Thunderbird 16.0.1

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: pitmancd, Unassigned)

Tracking

({perf})

16 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2013-01-18])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

I performed the latest update to 16.0.1.


Actual results:

After updating and starting Thunderbird 16 (within minutes), my Thunderbird and my system in general became incredibly slow.  When I play a YouTube video, for instance, the video is very choppy.  When I close Thunderbird, Windows (Win 7 64-bit), returns to normal...YouTube plays normal, etc.

I am using IMAP with Gmail.

I installed the latest version 17 beta.  It seemed to be normal, but I didn't run it long enough.  I reverted back to version 16 for calendar support (17 doesn't have this).

After re-installing version 16, it ran well for several hours.  But then the slow-down came back.




Expected results:

Thunderbird and my system should run normally, at "normal" speeds.
(Reporter)

Comment 1

6 years ago
BTW, I consider Thunderbird unusable at this point.  I am unable to do any other work on my PC when Thunderbird is open.
Severity: normal → critical

Comment 2

6 years ago
Can you see in tools->activity manager if TB is doing anything?

Also try to see in the Windows task manager whether Tb is using 100% of CPU or large amount of memory.
Are you using exetnsions ?
Keywords: perf

Comment 4

6 years ago
(In reply to Ludovic Hirlimann [:Usul] from comment #3)
> Are you using exetnsions ?

Even if you don't use extensions, please try http://support.mozillamessaging.com/en-US/kb/safe-mode  :)


(In reply to pitmancd from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML,
> like Gecko) Chrome/22.0.1229.94 Safari/537.4
> 
> Steps to reproduce:
> 
> I performed the latest update to 16.0.1.
> I installed the latest version 17 beta.  It seemed to be normal, but I
> didn't run it long enough.  I reverted back to version 16 for calendar
> support (17 doesn't have this).

see https://blog.mozilla.org/calendar/2012/10/lightning-1-9-will-be-the-esr-compatible-release-please-test-our-beta/

Comment 5

6 years ago
beta information is also typicallly availlable under the developer channel of https://addons.mozilla.org/en-US/thunderbird/addon/lightning/

also available for earlybird and dailies. see links at the right of https://blog.mozilla.org/calendar/
(Reporter)

Comment 6

6 years ago
I disabled all extensions and tried safe mode with the same results.  No difference.

I didn't notice a large amount of CPU usage in task manager, but I'll check again along with the memory.  And I'll check the activity manager (didn't know about this) and report back after the weekend, if not sooner.
(Reporter)

Comment 7

6 years ago
Ok, I came back and used Thunderbird successfully for about an hour last night.  After using it for about 1 hour this morning, my system came to a crawl again.  I tried closing/restarting Thunderbird but had the same results.

The activity manager shows only past events that had completed.  There was no current activity when the slow downs were occurring.

In Task Manager, CPU usage was 0.  Memory usage for TB was 352,760k.  Is this reasonable??

Comment 8

6 years ago
I think it's the same issue I recently reported to Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1068921
Please check if your mailbox is also growing.
Hotfix: Turn off offline synchronisation for all IMAP accounts.

The activity manager showed that mails from IMAP folders were downloaded again and again. Since my mail provider doesn't support unencrypted connections, I could not easily check what exactly is transferred all the time.
(Reporter)

Comment 9

6 years ago
Dietmar, thanks for the heads-up!

For the one IMAP account that I have, I went to Tools -> Account Settings -> Synchronization & Storage.  And then unchecked the top item "Keep messages for this account on this computer".  I will report back if that helps or not.

Is there a different/better way to turn off offline synchronization?

Also, I'm not certain how to check the mailbox size.  Maybe I should monitor this folder??

c:\Documents and Settings\Owner\AppData\Roaming\Thunderbird\Profiles\950vrfmk.default\ImapMail\imap.googlemail.com\
(Reporter)

Comment 10

6 years ago
Ok, what I did above didn't help.  Is there a different/better way to turn off offline synchronization?

Comment 11

6 years ago
(In reply to pitmancd from comment #9)
> Also, I'm not certain how to check the mailbox size.  Maybe I should monitor
> this folder??
> 
> c:\Documents and
> Settings\Owner\AppData\Roaming\Thunderbird\Profiles\950vrfmk.
> default\ImapMail\imap.googlemail.com\

Yes

Comment 12

6 years ago
(In reply to pitmancd from comment #10)
> Ok, what I did above didn't help.  Is there a different/better way to turn
> off offline synchronization?

No, that should be it. Did you restart Thunderbird after changing this?
(Reporter)

Comment 13

6 years ago
Yes, I restarted Thunderbird.  I'm going to try another restart, though.  If things change, I'll reply back.
(Reporter)

Comment 14

6 years ago
Just did it again...slow system.
(Reporter)

Comment 15

6 years ago
Having to go back to TB15.  If that doesn't work, I'll post a follow-up.
Having a stack trace of when it is slow would be interesting.
(Reporter)

Comment 17

6 years ago
Don't know what a stack trace is and how to do it.  You'll have to provide details.  But it may be awhile before I'm able to try version 16.x again.
(Reporter)

Comment 18

6 years ago
I've been on TB 15.x for a 3+ days now.  Everything had been working great up to this point, no problems.  I just had a slow down of my system, though, until I closed TB.  After restarting, the system slowed down again.  In the activity manager, the recent two entries were about deleting spam and updating my Trash folder.  Updating the trash folder took awhile and at one point it said it was "paused".  After those tasks completed, I closed TB because my system was still running slowly.  I think I originally had version 14.x before I upgraded to 16.x.  So, I may go back another version to 14.
(Reporter)

Comment 19

6 years ago
I went back to version 13.0.1.  And I'm having the same exact problem!

I guess I need to restore my system from a backup.

Or how can I completely do a fresh install of TB?  How do I delete profiles, user settings, etc.?  Do I need to go into the Windows registry, or is it just a matter of deleting folders?

Comment 20

6 years ago
try windows safe mode.

Comment 21

6 years ago
You can read the following pages to find out where the profile is and what the individual files contain. Then you can create a new profile and move only those valuable files into it.
http://kb.mozillazine.org/Profile_folder_-_Thunderbird
https://support.mozillamessaging.com/en-US/kb/profiles

Comment 22

6 years ago
pitmancd, did you have good results?
Flags: needinfo?(pitmancd)
Whiteboard: [closeme 2013-01-18]
(Reporter)

Comment 23

6 years ago
Sorry for the delay.  This issue can be closed.  As a coincidence, I had a network switch go bad intermittently - I think this was causing intermittent issues with Thunderbird.  Unfortunately, after the switch was replaced, the motherboard on the desktop PC that had the issues also died.  So, I can no longer confirm these issues reported on this bug, so please close.  My best guess is that it wasn't a Thunderbird issue but instead related to the network switch being bad.
Flags: needinfo?(pitmancd)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.