Last Comment Bug 803336 - SocialAPI Toolbar button needs 4 pixels of margin in toolbar
: SocialAPI Toolbar button needs 4 pixels of margin in toolbar
Status: VERIFIED FIXED
[qa-]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All Mac OS X
: -- major (vote)
: Firefox 19
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-18 16:13 PDT by Jennifer Morrow [:Boriss] (UX)
Modified: 2014-08-27 08:58 PDT (History)
9 users (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
verified


Attachments
Mockup: Toolbar at current state and goal state (374.00 KB, image/png)
2012-10-18 16:15 PDT, Jennifer Morrow [:Boriss] (UX)
no flags Details
osxfix (530 bytes, patch)
2012-10-23 19:50 PDT, Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16]
no flags Details | Diff | Review
Patch (1014 bytes, patch)
2012-10-26 13:45 PDT, Jared Wein [:jaws] (please needinfo? me)
felipc: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Review

Description Jennifer Morrow [:Boriss] (UX) 2012-10-18 16:13:25 PDT
Currently, the SocialAPI toolbar button is 4 pixels too close to the right side of the Firefox window and 4 pixels too close to the toolbar button on its left.

I'm using OSX and am not sure if this problem occurs in Windows or Linux.
Comment 1 Jennifer Morrow [:Boriss] (UX) 2012-10-18 16:15:01 PDT
Created attachment 672999 [details]
Mockup: Toolbar at current state and goal state
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-10-22 00:46:53 PDT
I think this is only on OS X.
Comment 3 edA-qa mort-ora-y 2012-10-22 00:48:31 PDT
I can confirm that on Linux (Ubunut/KDE 12.04) the icon also looks too close to the "star" beside it.
Comment 4 Chris More [:cmore] 2012-10-22 15:30:48 PDT
+1 I agree.
Comment 5 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-10-23 19:50:47 PDT
Created attachment 674508 [details] [diff] [review]
osxfix

I don't have access to linux right now, but this fixes osx.
Comment 6 Shane Caraveo (:mixedpuppy) [on leave 5/16-7/16] 2012-10-23 20:19:33 PDT
(In reply to edA-qa mort-ora-y from comment #3)
> I can confirm that on Linux (Ubunut/KDE 12.04) the icon also looks too close
> to the "star" beside it.

Are you talking about the toolbar button, or the recommend button in the url bar?  see bug 803514
Comment 7 edA-qa mort-ora-y 2012-10-24 00:03:46 PDT
(In reply to Shane Caraveo (:mixedpuppy) from comment #6)
> (In reply to edA-qa mort-ora-y from comment #3)
> > I can confirm that on Linux (Ubunut/KDE 12.04) the icon also looks too close
> > to the "star" beside it.
> Are you talking about the toolbar button, or the recommend button in the url
> bar?  see bug 803514

Oops, yes, I mean the recommend icon in the url bar. The toolbar buttons in Linux look okay (at least to my eyes).
Comment 8 Jared Wein [:jaws] (please needinfo? me) 2012-10-24 12:55:41 PDT
Comment on attachment 674508 [details] [diff] [review]
osxfix

Review of attachment 674508 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/themes/pinstripe/browser.css
@@ +4041,5 @@
>  
>  /* button icon for the service */
>  #social-toolbar-item {
>    -moz-box-orient: horizontal;
> +  margin: 0 4px;

If the margins between buttons changes in the future, then this will get out of date.

I'd rather do the following,

#social-toolbar-item > .toolbarbutton-1:not(:first-child):not(:last-child) {
  margin: 0;
}
#social-toolbar-item > .toolbarbutton-1:first-child {
  -moz-margin-end: 0;
}
#social-toolbar-item > .toolbarbutton-1:last-child {
  -moz-margin-start: 0;
}
Comment 9 Jared Wein [:jaws] (please needinfo? me) 2012-10-26 13:45:17 PDT
Created attachment 675677 [details] [diff] [review]
Patch
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-10-26 15:54:32 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/124486383375
Comment 11 Jared Wein [:jaws] (please needinfo? me) 2012-10-26 15:57:48 PDT
Comment on attachment 675677 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: social api toolbar will be too close to other toolbar buttons on mac os x
Testing completed (on m-c, etc.): locally, just landed on m-i
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-10-27 13:49:28 PDT
https://hg.mozilla.org/mozilla-central/rev/124486383375
Comment 14 Bogdan Maris, QA [:bogdan_maris] 2013-02-08 04:55:53 PST
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
BuildID: 20130206083616

Verified as fixed on Firefox 19 Beta 5 and latest Nightly (BuildID: 20130207030936)

Note You need to log in before you can comment on or make changes to this bug.