[socorro-crashstats] test_that_search_for_valid_signature is failing

VERIFIED FIXED

Status

Socorro
Webapp
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: stephend, Assigned: rhelmer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
test_that_search_for_valid_signature [1] is failing:

self = <tests.test_search.TestSearchForIdOrSignature instance at 0x1775238>
mozwebqa = <pytest_mozwebqa.pytest_mozwebqa.TestSetup instance at 0x17873f0>

@pytest.mark.nondestructive
def test_that_search_for_valid_signature(self, mozwebqa):
"""
This is a test for
https://bugzilla.mozilla.org/show_bug.cgi?id=609070
"""
csp = CrashStatsHomePage(mozwebqa)
report_list = csp.click_last_product_top_crashers_link()
signature = report_list.first_signature_title

result = csp.header.search_for_crash(signature)
> Assert.true(result.are_results_found)

tests/test_search.py:45:
_ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _

self = <class unittestzero.Assert at 0x14a10f0>, first = False, msg = None

@classmethod
def true(self, first, msg=None):
"""
Asserts that what is given is equal to True

:Args:
- First object to be tested
- Message that will be printed if it fails
"""

> assert first is True, msg
E assert False is True

.env/lib/python2.6/site-packages/unittestzero.py:77: AssertionError

[1] https://github.com/mozilla/Socorro-Tests/blob/master/tests/test_search.py#L34
I can't reproduce this locally. Stephen, do you have steps to reproduce this? Here is what I am doing: 

1. Go to home page
2. Click topcrasher for the last version (ie Firefox release)
3. Copy the first signature, paste in the upper form and start a search
4. Verify that there are results on the /query page.

Doing that, I indeed get results. Did I miss something in the test?
(Reporter)

Comment 2

5 years ago
Pretty sure this is just a locator issue, which brings up the whole "do we really want DOM for DOM" compatibility between the current and Django-rewrite sites.
(Assignee)

Comment 3

5 years ago
I have selenium running locally (against my local crash-stats instance), so I can take a look.

(In reply to Stephen Donner [:stephend] from comment #2)
> Pretty sure this is just a locator issue, which brings up the whole "do we
> really want DOM for DOM" compatibility between the current and
> Django-rewrite sites.

I think we do want compatibility unless there's a good reason not to. We should at least understand the reason we're breaking it ;)
Assignee: nobody → rhelmer
Status: NEW → ASSIGNED
(Assignee)

Comment 4

5 years ago
The problem is that the table id has changed from signatureList to signatures-list.

I went ahead and changed it (and the tests+js that refer to it) back:

r? https://github.com/mozilla/socorro-crashstats/pull/209
URL:

Comment 5

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro-crashstats

https://github.com/mozilla/socorro-crashstats/commit/82661f654e2e139bdc97fc4cda3deda0f8cd230d
bug 803755 - fix failing selenium test test_that_search_for_valid_signature by changing signatures-list back to signatureList

https://github.com/mozilla/socorro-crashstats/commit/9637f6c6efef82c9a2eabfa2a62ac15d524d5c43
Merge pull request #209 from rhelmer/bug803755-search-test-failing

bug 803755 - fix failing selenium test test_that_search_for_valid_signat...
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Created attachment 674320 [details]
Post-fix screenshot
You need to log in before you can comment on or make changes to this bug.