Last Comment Bug 803794 - crash in nsMediaPluginHost::CreateDecoder @ libomxplugin.so@0xe.. on Sony devices with Adreno 220/225 GPUs running ICS
: crash in nsMediaPluginHost::CreateDecoder @ libomxplugin.so@0xe.. on Sony dev...
Status: RESOLVED FIXED
[native-crash], [swdecoder]
: crash, regression, topcrash
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 17 Branch
: ARM Android
: -- critical (vote)
: mozilla19
Assigned To: cajbir (:cajbir)
:
Mentors:
Depends on: 806369
Blocks: 787319 782508 817478
  Show dependency treegraph
 
Reported: 2012-10-19 23:46 PDT by Scoobidiver (away)
Modified: 2012-12-02 20:02 PST (History)
9 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
+
fixed
+
fixed
17+


Attachments

Description Scoobidiver (away) 2012-10-19 23:46:06 PDT
Filed per bug 787319 comment 23.
This crash signature is #1 top crasher in 17.0b1.

Here are correlations per device based on https://crash-analysis.mozilla.com/rkaiser/2012-10-18/2012-10-18.fennecandroid.beta.17.0.devices.weekly.html#sigs:
* libomxplugin.so@0xe37 	984
Sony Ericsson LT26i 	684
Sony Ericsson LT22i 	133
Sony ST25i 	31
Sony Ericsson LT28h 	27
Sony MT27i 	24
Sony LT30p 	23
Sony Ericsson LT26w 	18
Sony Ericsson IS12S 	16
Sony Ericsson LT28at 	11
Sony Ericsson LT26ii 	9
Sony ST27i 	6
Sony Ericsson LT28i 	2

Signature 	libomxplugin.so@0xe37 More Reports Search
UUID	435c5fc7-4a09-4e9b-ac2d-5b0282121020
Date Processed	2012-10-20 05:33:32
Uptime	291
Install Age	1.1 weeks since version was first installed.
Install Time	2012-10-12 16:56:20
Product	FennecAndroid
Version	17.0
Build ID	20121010211745
Release Channel	beta
OS	Linux
OS Version	0.0.0 Linux 3.0.8+ #1 SMP PREEMPT Fri Jul 13 14:59:29 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0xc77a04ec
App Notes 	
AdapterDescription: 'ARM -- Mali-400 MP -- OpenGL ES 2.0 -- Model: LT22i, Product: LT22i_1261-5825, Manufacturer: Sony Ericsson, Hardware: st-ericsson'
EGL? EGL+ GL Context? GL Context+ GL Layers? GL Layers+ 
Sony Ericsson LT22i
SEMC/LT22i_1261-5825/LT22i:4.0.4/6.1.B.0.544/371_zw:user/release-keys
EMCheckCompatibility	True
Adapter Vendor ID	ARM
Adapter Device ID	Mali-400 MP
Device	Sony Ericsson LT22i
Android API Version	15 (REL)
Android CPU ABI	armeabi-v7a

Frame 	Module 	Signature 	Source
0 		@0xc77a04ec 	
1 	libomxplugin.so 	libomxplugin.so@0xe37 	
2 	libstagefright.so 	libstagefright.so@0x63a93 	
3 	libstagefright.so 	libstagefright.so@0x63aa7 	
4 	libutils.so 	libutils.so@0x20b77 	
5 	libstagefright.so 	libstagefright.so@0x63a93 	
6 	libstagefright.so 	libstagefright.so@0x63a93 	
7 	libstagefright.so 	libstagefright.so@0x63993 	
8 	libstagefright.so 	libstagefright.so@0x14385e 	
9 	libstagefright.so 	libstagefright.so@0x13cce6 	
10 	libstagefright.so 	libstagefright.so@0x7432b 	
11 	libomxplugin.so 	OmxDecoder::Init 	OmxPlugin.cpp:411
12 		@0x7 	
13 	libomxplugin.so 	CreateDecoder 	OmxPlugin.cpp:820
14 	libxul.so 	nsMediaPluginHost::CreateDecoder 	content/media/plugins/nsMediaPluginHost.cpp:149
15 	libxul.so 	nsMediaPluginReader::ReadMetadata 	content/media/plugins/nsMediaPluginReader.cpp:44
16 	libxul.so 	nsBuiltinDecoderStateMachine::DecodeMetadata 	content/media/nsBuiltinDecoderStateMachine.cpp:1720
17 	libxul.so 	nsBuiltinDecoderStateMachine::DecodeThreadRun 	content/media/nsBuiltinDecoderStateMachine.cpp:479
18 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:349
19 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
20 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:220
21 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:257
22 	libnspr4.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:156
23 	libc.so 	libc.so@0x12eee 	
24 	libc.so 	libc.so@0x12a42

More reports at:
https://crash-stats.mozilla.com/report/list?signature=libomxplugin.so%400xe37
Comment 1 Scoobidiver (away) 2012-10-21 06:08:39 PDT
There are no crashes in 17.0b2 with this crash signature.
The new top crasher is with the libomxplugin.so@0xedb signature (tracked in bug 787319). Should I file a new bug for this crash signature or add the crash signature to this bug?
Comment 2 Chris Peterson [:cpeterson] 2012-10-22 10:41:13 PDT
Even though libomxplugin.so@0xedb has a different crash address, it looks almost identical to this crash. The crash address is very close within the same library and all the reports are from Sony Ericsson devices running ICS 4.0.4.
Comment 3 Scoobidiver (away) 2012-10-25 10:25:24 PDT
It's still #1 top crasher in 17.0b3. Is there any updates on the patch that was in bug 787319?
Comment 5 Maire Reavy (On PTO July 23rd to 31st) 2012-10-30 12:03:09 PDT
The plan is to land Bug 806369 (create a blacklist) to deal with this blocker issue here for Firefox 17.  The root cause fix will addressed after Firefox 17.
Comment 6 Lukas Blakk [:lsblakk] use ?needinfo 2012-11-07 15:46:08 PST
We'll check back after beta 5 has been available a few days to ensure that the blacklist successfully decreased the crashes here.
Comment 7 Scoobidiver (away) 2012-11-08 00:45:14 PST
(In reply to Lukas Blakk [:lsblakk] from comment #6)
> the blacklist successfully decreased the crashes here.
The mechanism to blacklist is indeed in 17.0 Beta but no devices are blocked for StageFright. See https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Android
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-11-08 10:12:38 PST
(In reply to Scoobidiver from comment #7)
> (In reply to Lukas Blakk [:lsblakk] from comment #6)
> > the blacklist successfully decreased the crashes here.
> The mechanism to blacklist is indeed in 17.0 Beta but no devices are blocked
> for StageFright. See
> https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Android

we're actually white listing for ICS, not black listing. We're black listing for JB
Comment 9 Scoobidiver (away) 2012-11-09 05:06:05 PST
(In reply to Brad Lassey [:blassey] from comment #8)
> we're actually white listing for ICS, not black listing. We're black listing
> for JB
Indeed, you're right and I was wrong. I've updated https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers#On_Android_2 accordingly.
As a consequence, these crashes will be fixed in 17.0b5 as stated by Lukas in comment 6.
Comment 10 Scoobidiver (away) 2012-11-10 06:10:34 PST
Because of the StageFright blacklisting on ICS except for Samsung devices, there are no crashes in 17.0b5 and after 18.0a2/20121108.
The underlying issue is not fixed though.
Comment 11 bhavana bajaj [:bajaj] 2012-11-12 15:45:50 PST
(In reply to Maire Reavy [:mreavy] from comment #5)
> The plan is to land Bug 806369 (create a blacklist) to deal with this
> blocker issue here for Firefox 17.  The root cause fix will addressed after
> Firefox 17.

Hey Maire, can you please pass on the bug # where the root cause of this issue is being addressed ?
Comment 12 cajbir (:cajbir) 2012-11-13 11:43:09 PST
Should this be untracked for FF18 given that it no longer crashes due to the blocklist? The underlying issue won't be fixed for FF18 if a fix is required by 19/11.
Comment 13 Robert Kaiser 2012-11-13 13:06:00 PST
I agree with Chris in comment #12, I guess we can just mark it fixed for 18 as well and track for the current trunk instead.
Comment 14 Scoobidiver (away) 2012-11-13 23:03:08 PST
Fixed by bug 806369.
Comment 15 cajbir (:cajbir) 2012-12-02 20:02:59 PST
(In reply to bhavana bajaj [:bajaj](on vacation until 12/10.Please reach out to akeybl/lsblakk for anything urgent) from comment #11)
> 
> Hey Maire, can you please pass on the bug # where the root cause of this
> issue is being addressed ?


Raised bug 817478 for this.

Note You need to log in before you can comment on or make changes to this bug.