Closed Bug 817478 Opened 7 years ago Closed 7 years ago

Fix root cause of crash in nsMediaPluginHost::CreateDecoder @ libomxplugin.so@0xe.. on Sony devices with Adreno 220/225 GPUs running ICS

Categories

(Core :: Audio/Video, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox17 - affected
firefox18 - affected
firefox19 --- affected
fennec 17+ ---

People

(Reporter: cajbir, Assigned: cajbir)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression, Whiteboard: [native-crash], [swdecoder])

Crash Data

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #803794 +++

Filed per bug 787319 comment 23.
This crash signature is #1 top crasher in 17.0b1.

Here are correlations per device based on https://crash-analysis.mozilla.com/rkaiser/2012-10-18/2012-10-18.fennecandroid.beta.17.0.devices.weekly.html#sigs:
* libomxplugin.so@0xe37 	984
Sony Ericsson LT26i 	684
Sony Ericsson LT22i 	133
Sony ST25i 	31
Sony Ericsson LT28h 	27
Sony MT27i 	24
Sony LT30p 	23
Sony Ericsson LT26w 	18
Sony Ericsson IS12S 	16
Sony Ericsson LT28at 	11
Sony Ericsson LT26ii 	9
Sony ST27i 	6
Sony Ericsson LT28i 	2

Signature 	libomxplugin.so@0xe37 More Reports Search
UUID	435c5fc7-4a09-4e9b-ac2d-5b0282121020
Date Processed	2012-10-20 05:33:32
Uptime	291
Install Age	1.1 weeks since version was first installed.
Install Time	2012-10-12 16:56:20
Product	FennecAndroid
Version	17.0
Build ID	20121010211745
Release Channel	beta
OS	Linux
OS Version	0.0.0 Linux 3.0.8+ #1 SMP PREEMPT Fri Jul 13 14:59:29 2012 armv7l
Build Architecture	arm
Build Architecture Info	
Crash Reason	SIGSEGV
Crash Address	0xc77a04ec
App Notes 	
AdapterDescription: 'ARM -- Mali-400 MP -- OpenGL ES 2.0 -- Model: LT22i, Product: LT22i_1261-5825, Manufacturer: Sony Ericsson, Hardware: st-ericsson'
EGL? EGL+ GL Context? GL Context+ GL Layers? GL Layers+ 
Sony Ericsson LT22i
SEMC/LT22i_1261-5825/LT22i:4.0.4/6.1.B.0.544/371_zw:user/release-keys
EMCheckCompatibility	True
Adapter Vendor ID	ARM
Adapter Device ID	Mali-400 MP
Device	Sony Ericsson LT22i
Android API Version	15 (REL)
Android CPU ABI	armeabi-v7a

Frame 	Module 	Signature 	Source
0 		@0xc77a04ec 	
1 	libomxplugin.so 	libomxplugin.so@0xe37 	
2 	libstagefright.so 	libstagefright.so@0x63a93 	
3 	libstagefright.so 	libstagefright.so@0x63aa7 	
4 	libutils.so 	libutils.so@0x20b77 	
5 	libstagefright.so 	libstagefright.so@0x63a93 	
6 	libstagefright.so 	libstagefright.so@0x63a93 	
7 	libstagefright.so 	libstagefright.so@0x63993 	
8 	libstagefright.so 	libstagefright.so@0x14385e 	
9 	libstagefright.so 	libstagefright.so@0x13cce6 	
10 	libstagefright.so 	libstagefright.so@0x7432b 	
11 	libomxplugin.so 	OmxDecoder::Init 	OmxPlugin.cpp:411
12 		@0x7 	
13 	libomxplugin.so 	CreateDecoder 	OmxPlugin.cpp:820
14 	libxul.so 	nsMediaPluginHost::CreateDecoder 	content/media/plugins/nsMediaPluginHost.cpp:149
15 	libxul.so 	nsMediaPluginReader::ReadMetadata 	content/media/plugins/nsMediaPluginReader.cpp:44
16 	libxul.so 	nsBuiltinDecoderStateMachine::DecodeMetadata 	content/media/nsBuiltinDecoderStateMachine.cpp:1720
17 	libxul.so 	nsBuiltinDecoderStateMachine::DecodeThreadRun 	content/media/nsBuiltinDecoderStateMachine.cpp:479
18 	libxul.so 	nsRunnableMethodImpl<void , true>::Run 	nsThreadUtils.h:349
19 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:624
20 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:220
21 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:257
22 	libnspr4.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:156
23 	libc.so 	libc.so@0x12eee 	
24 	libc.so 	libc.so@0x12a42

More reports at:
https://crash-stats.mozilla.com/report/list?signature=libomxplugin.so%400xe37

Bug 803794 was resolved by blacklisting the device. This bug is to fix the root cause of the issue so the blacklist can be lifted.
Assignee: nobody → chris.double
Status: NEW → ASSIGNED
Attachment #687610 - Flags: review?(cpeterson)
Attachment #687611 - Flags: review?(mark.finkle)
The patches fix the software decoder. Bug 803394 fixes the hardware decoder side of things.
Attachment #687611 - Flags: review?(mark.finkle) → review+
Comment on attachment 687610 [details] [diff] [review]
Part1: Media plugin backend changes for sony device support

Review of attachment 687610 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Attachment #687610 - Flags: review?(cpeterson) → review+
These tracking flags came over from the clone. Bug 806369 blacklisted these devices, so we don't need to track for upcoming releases. If a low risk uplift is desired, please nominate for approval.
You need to log in before you can comment on or make changes to this bug.