Status

Developer Services
General
--
major
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: aryx, Assigned: jakem)

Tracking

Details

MXR for mozilla-aurora hasn't yet picked up changes from Tuesday.

https://hg.mozilla.org/releases/mozilla-aurora/file/db0f6c3046b2/browser/devtools/commandline/CmdJsb.jsm#l77
has the entitites 'jsbBraceStyleDesc2' and 'jsbBraceStyleManual2' from commit https://hg.mozilla.org/releases/mozilla-aurora/rev/a02e939d3088 pushed on 2012-10-16, see bug 799462.
MXR has still the old entities, see http://mxr.mozilla.org/mozilla-aurora/source/browser/devtools/commandline/CmdJsb.jsm#76
Assignee: nobody → server-ops-devservices
Component: MXR → Server Operations: Developer Services
Product: Webtools → mozilla.org
QA Contact: shyam
Version: Trunk → other
Actually this extends to at least comm-central and mozilla-central, so I'm betting on all of mxr.

For example test_bug627234.js was added by bug 627234 on Monday (Mon Oct 22 18:41:58 2012 -0700) and that isn't showing up in comm-central nor mozilla-central.
Severity: normal → major
Summary: MXR for mozilla-aurora doesn't update → MXR not updating

Updated

5 years ago
Assignee: server-ops-devservices → shyam
Pretty sure this is because of a stuck cronjob. Working on cleaning all that up.
Seems fine now, http://mxr.mozilla.org/mozilla-aurora/source/browser/devtools/commandline/CmdJsb.jsm?rev=a02e939d3088#76
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
The url you provided contains a revision, but searching http://mxr.mozilla.org/mozilla-aurora/ doesn't contain this and also still doesn't find jsbBraceStyleManual2. Is the fact what the bug has been fixed in the last 24 hours and mxr not yet updated its index the reason for this?
Going to CC Jake here..mxr should have caught this. I'll work with him and see what's going on.
(In reply to Archaeopteryx [:aryx] from comment #4)
> The url you provided contains a revision, but searching
> http://mxr.mozilla.org/mozilla-aurora/ doesn't contain this and also still
> doesn't find jsbBraceStyleManual2. Is the fact what the bug has been fixed
> in the last 24 hours and mxr not yet updated its index the reason for this?

No, there seems to be an issue with aurora, we're looking again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

5 years ago
Not sure what's up, but I recommended to fox2mike to run the update-search.pl script by hand, to re-index mozilla-aurora. Do we suspect any other trees might still be messed up? The stuff in comment 1 seems resolved now, so I'm inclined to believe it's just mozilla-aurora.
(In reply to Jake Maul [:jakem] from comment #7)
> Not sure what's up, but I recommended to fox2mike to run the
> update-search.pl script by hand, to re-index mozilla-aurora. Do we suspect
> any other trees might still be messed up? The stuff in comment 1 seems
> resolved now, so I'm inclined to believe it's just mozilla-aurora.

Jake, still no go. If I hit up http://mxr.mozilla.org/mozilla-aurora/search?string=jsbBraceStyleManual2 it shows nothing.

Updated

5 years ago
Duplicate of this bug: 810528
(Assignee)

Comment 10

5 years ago
Hmm...



[root@mxr-processor1.private.scl3 mozilla-aurora]# hg pull
warning: hg.mozilla.org certificate with fingerprint 10:78:e8:57:2d:95:de:7c:de:90:bd:22:e1:38:17:67:c5:a7:9c:14 not verified (check hostfingerprints or web.cacerts config setting)
pulling from https://hg.mozilla.org/releases/mozilla-aurora
searching for changes
adding changesets
adding manifests
adding file changes
added 114 changesets with 169 changes to 122 files (-6 heads)
(run 'hg update' to get a working copy)
[root@mxr-processor1.private.scl3 mozilla-aurora]# hg update
abort: crosses branches (merge branches or use --clean to discard changes)

Did someone do something... "interesting" to mozilla-aurora? I'm not sure what can cause this.

[root@mxr-processor1.private.scl3 mozilla-aurora]# hg update --clean
15745 files updated, 0 files merged, 182 files removed, 0 files unresolved


Processing now, I think we're back to normal.
(In reply to Jake Maul [:jakem] from comment #10)
> Did someone do something... "interesting" to mozilla-aurora? I'm not sure
> what can cause this.

That's usually what happens after every uplift (every 6 weeks), when we kill off the old default branch and create a new head. Have we run into this problem before?
(Assignee)

Comment 12

5 years ago
As far as I know this is a first occurrence... at least, if we have seen it before, nobody's mentioned it to me. Given that it would about 4 times every 6 weeks (once for each channel, each uplift), I should have heard plenty about it long before now.

I didn't think to do an "hg status" before starting the "hg update --clean", so sadly I don't know precisely what it was unhappy about.

As mentioned in bug 810528, there was a stale lockfile left hanging around on Oct 26... too late to be the cause of this bug, but definitely the cause of many other trees going stale after that.

I'm content to chalk this up to bad luck for now, and revisit should it happen again. If it's an inherent problem with the changesets, we should see it again once the same code/changesets hit beta and release. If it was a problem with the process in general, we'd expect to hit it far more frequently (eg: more than one time).

Processing is completed, and that search returns results now:
http://mxr.mozilla.org/mozilla-aurora/search?string=jsbBraceStyleManual2



I'm wondering if we should be doing "hg pull && hg update --clean" instead of "hg pull -u" in the general case. That would have avoided this problem, and seems like a reasonable default. "--clean", as far as I can tell, discards any local / uncommitted changes to the working directory. It does not remove any untracked files (like last-processed), so it won't break that. I can't tell if it takes any longer on average.

Thoughts on this?
(Assignee)

Comment 13

5 years ago
Note: if we want to make that change, it would be hg_update() in update-src.pl...

http://hg.mozilla.org/webtools/mxr/file/98def7dd42a4/update-src.pl#l88
(In reply to Jake Maul [:jakem] from comment #12)
> I'm wondering if we should be doing "hg pull && hg update --clean" instead
> of "hg pull -u" in the general case. That would have avoided this problem,
> and seems like a reasonable default.

Sounds like a good idea to me!
Are we good here?  Seems like Jake fixed the issue? 

Gavin/Jake, who has access to commit to mxr on hg, so we can put this in the update script?
Assignee: shyam → nmaul
(Assignee)

Comment 16

5 years ago
I have commit access to that repo... not sure who else does apart from just trolling the commit history.

I don't have a patched worked up, but can work on that... will probably want an r+ from someone before committing/deploying it... and might want to try it out on a single repo by hand first. :)
(Assignee)

Comment 17

5 years ago
I've committed a fix that I think will do the job.

http://hg.mozilla.org/webtools/mxr/rev/0286fc2765bf

I've processed a few trees by hand and it seems to work properly.

That should be it here. Closing this bug.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
mozilla-beta still seems to be wedged.
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.