"Restart to Update" button label in about dialog is vague

VERIFIED FIXED in Firefox 34

Status

()

VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: david.balazic, Assigned: aria, Mentored)

Tracking

16 Branch
Firefox 34
x86
Windows XP
Points:
1
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140827] [bugday-20131007] [good first bug][lang=xul])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Open the About dialog (running FF 15.0.1)


Actual results:

Dialog was opened, update to 16.0.1 was downloaded.
Then a button labeled "Restart to Update" appeared in the dialog.


Expected results:

The button label should say "Restart Firefox to update".

I did some other (OS and other apps) updates the same time and realized the vagueness of the button label. The Windows update has also a button saying "Restart now".

So the FF button could be misunderstood as if it would restart the whole computer, not just Firefox.

Updated

5 years ago
Duplicate of this bug: 828544

Updated

5 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
Whiteboard: [bugday-20131007]
This *is* confusing.  I cringe to think users may be restarting their entire computer over this.  Adding to the backlog.
Flags: firefox-backlog+

Updated

5 years ago
Duplicate of this bug: 1013403

Comment 4

5 years ago
I have the two idea.

1. Replace with "Restart &brandShortName; to Update". However, the button width may be too long, especially in Thunderbird, will be unsightly. In addition, the "Update" be initial capital letters are necessary?

2. Add a tooltip to the button, provide limited helpful. e.g. "Restart the Firefox to done update." or "Restart Firefox to done the update", I'm not sure which is correct grammar.
(In reply to YF (Yang) from comment #4)
> 1. Replace with "Restart &brandShortName; to Update". However, the button
> width may be too long, especially in Thunderbird, will be unsightly. In
> addition, the "Update" be initial capital letters are necessary?

Let's do this!

Updated

4 years ago
Whiteboard: [bugday-20131007] → [bugday-20131007] p=1

Updated

4 years ago
Points: --- → 1
Whiteboard: [bugday-20131007] p=1 → [bugday-20131007]
Those looking to solve this bug: Use DXR[1] to find the string in question. "Restart Firefox to Update" seems like a sensible replacements. Use the entity &brandShortName; in place of Firefox since the browser might be named something else.

Let me know if you have any questions.


 [1]: http://dxr.mozilla.org
Mentor: manishearth
Whiteboard: [bugday-20131007] → [bugday-20131007] [good first bug]
Whiteboard: [bugday-20131007] [good first bug] → [bugday-20131007] [good first bug][lang=xul]
(Assignee)

Comment 7

4 years ago
Created attachment 8474154 [details] [diff] [review]
803812-restarttoupdate.patch

This patch should cover it for the main UI, but I noticed there's a different "Restart to Update" in /browser/metro which I'm not sure if needs anything.
Attachment #8474154 - Flags: review?(bmcbride)
Comment on attachment 8474154 [details] [diff] [review]
803812-restarttoupdate.patch

Review of attachment 8474154 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch, Alli :)

Firefox for Metro (/browser/metro) isn't being actively developed anymore, so you don't need to worry about changing the string there (though you're welcome to file a separate bug for it if you'd like).

::: browser/locales/en-US/chrome/browser/aboutDialog.dtd
@@ +9,5 @@
>  # the about dialog (see bug 596813 for screenshots).
>  -->
>  <!ENTITY update.checkForUpdatesButton.label       "Check for updates">
>  <!ENTITY update.checkForUpdatesButton.accesskey   "C">
> +<!ENTITY update.updateButton.label                "Restart &brandShortName; to Update">

Unfortunately, whenever we change either the content of a string, or the context where it's used, we need to also change it's ID - otherwise it's too easy for localizers to miss the change and not update the string.

The usual convention in this case is to change the ID to update.updateButton.label2
Attachment #8474154 - Flags: review?(bmcbride) → review-
(Assignee)

Comment 9

4 years ago
Understandable. Updating the key and where it was used to point to the new key--is there anything else?
(In reply to Alli (Aria) Grant from comment #9)
> Understandable. Updating the key and where it was used to point to the new
> key--is there anything else?

That's it!
(Assignee)

Comment 11

4 years ago
Created attachment 8474195 [details] [diff] [review]
803812-restarttoupdate-2.patch

Round two, since this looks to be the only use.
Attachment #8474154 - Attachment is obsolete: true
Attachment #8474195 - Flags: review?(bmcbride)
Comment on attachment 8474195 [details] [diff] [review]
803812-restarttoupdate-2.patch

Review of attachment 8474195 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the patch!
Attachment #8474195 - Flags: feedback+
Comment on attachment 8474195 [details] [diff] [review]
803812-restarttoupdate-2.patch

Review of attachment 8474195 [details] [diff] [review]:
-----------------------------------------------------------------

Great :)

(Will make this as checkin?, so someone else can land it when they have time.)
Attachment #8474195 - Flags: review?(bmcbride)
Attachment #8474195 - Flags: review+
Attachment #8474195 - Flags: checkin?
Comment on attachment 8474195 [details] [diff] [review]
803812-restarttoupdate-2.patch

FWIW, checkin-needed plays more nicely with our bug marking tools :)
Attachment #8474195 - Flags: checkin? → checkin+
https://hg.mozilla.org/mozilla-central/rev/1a5773f24770
Assignee: nobody → aria
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
QA Whiteboard: [qa-]

Updated

4 years ago
Iteration: --- → 34.2
QA Whiteboard: [qa-]
Flags: qe-verify-

Comment 16

4 years ago
Verified on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0 ID:20140827030202 CSet: 0753f7b93ab7
Status: RESOLVED → VERIFIED
Whiteboard: [bugday-20131007] [good first bug][lang=xul] → [bugday-20140827] [bugday-20131007] [good first bug][lang=xul]
You need to log in before you can comment on or make changes to this bug.